350 hard starting & won't rev - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-08-2002, 07:49 PM
Registered User
 
Join Date: Oct 2002
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post 350 hard starting & won't rev

I have a chevy 350 installed in a 87 Fiero GT, 5-speed. It has an edelbrock performer intake & a Performer series 600cfm carb.

The biggest problem I'm having is that under load, ie driving, it won't rev past 4k rpm. It pulls nice and hard up to around 4k then it won't go any more. Even If I put it in first gear and go WOT it won't rev higher than 4k. I've checked to see if the timing is advancing and it was.

The other problem is when the engine is hot and you let it sit for awhile it cranks forever(5-10 sec)before it will start. When The engine is cold it fire's right up.

Any thoughts or ideas?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-08-2002, 08:22 PM
Registered User
 
Join Date: Aug 2002
Location: C.T.
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

WHY WOULD YOU???? But anyway it must rip. It sounds like vapor lock. check your fuel pressure cold and then hot. with the engine in back, it may be a heat box back there> Just a suggestion.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-09-2002, 10:05 AM
tonylsg's Avatar
Member
 
Join Date: Oct 2002
Location: Union Grove, AL
Age: 32
Posts: 109
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

i have a chevy 350 in my 85 silverado and had the same problem with the motor not turning more than 4k. the first thing is what kind of cam are you
running and do you have any head work. some chevy cams are not meant to pull over 4k and the same applies to their heads. i went with a crane cam and gained 1000 rpms, 1.6 roller rockers(300 rpms), after i get the heads worked probably more than that. hope this helps. Tony
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.