Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 350 high starter choice?
View Single Post
  #19 (permalink)  
Old 02-03-2013, 10:04 AM
Jaykobo Jaykobo is offline
Registered User
 
Join Date: Aug 2012
Posts: 24
Wiki Edits: 0

Thanks: 3
Thanked 0 Times in 0 Posts
it's 10.5 CR........I think the KB climer piston...when it getting tight to the cylinder wall....extended with the heat as the tech tell me....it's the first start for the engine and need to be trained....I just run it totally 24hr.....I belive the engine will work much better after it's trained and turn easily

and take a round with it slowly for 30 km...........some told me the timing....and I adjust it ....sure it work greater but the starter the same.....also the ICM ...was bad and I change it with Dyno one from summit

Davis Unified Ignition Dyna-Modules 000444 - SummitRacing.com


it's miss fire the engine and make it shut off....I replace it with cheap used one from the JY... 10 $us and work fine...but the part not reliable.


and I read a lot talking about cables....I check it for worn,cut,corrosion,heat and test it with clamp meter.... .it's ok....even though I bought new cables from local shop....the same

I replace the starter with AC delco remunfactured....the same



I have 3 engines in my home.....I but the old starter on stock 305 engine working great with the same cables....but on the first one....slowly

the starter working great when the battery full charged 13.4 volt.......but once the drop to 12.75...it's start working weak.....when it's 12.2 V the starter almost stop....I changed the battery with higher amper "the stock was 73A I bought 78A......work little bit better...so I finally decide the starter is the problem

so I,m sure it's the starter.......sorry for taking long.....now all is fine only the starter
Reply With Quote