Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 350 misfire/backfire
View Single Post
  #4 (permalink)  
Old 11-07-2012, 04:29 PM
cobalt327's Avatar
cobalt327 cobalt327 is offline
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 595 Times in 545 Posts
Quote:
Originally Posted by Stormtrooper View Post
Alright so i have a 350 engine, vortec heads, edelbrock intake, comp roller tip rockers, 650 edelbrock thunder series carb. Intial timing at 11 degrees.

Right now it idles terribly, backfires out the back some and wants to die if i dont let it warm up enough for driving. Also misfires at any engine speed(dash shaking) and im way down on power.

I replaced the cap, rotor, coil, control module and the plugs when the module went out a few weeks ago.

i adjusted the valves messed with the carb adjustments when misfire started and still nothing. also ran some seafoam through the tank and carb still nothing. iv been hella busy with work though so i dont know when exactly the problem started. The plugs were black so im thinking i might lean it out with a rod change but it has always run rich. even before the problem started just havent got around to getting new rods or springs for it.

any help is appreciated as this is very annoying
It might be a case of the timing being off. Check to see if the distributor is loose in the engine and has let the timing wander.

Be sure plug wires for #5 and #7 weren't accidentally swapped. Check at night w/the engine running to see if there's arcing between the wires and a ground or between the wires themselves.
Reply With Quote