Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 350 TBI first time rebuilding engine...question
View Single Post
  #14 (permalink)  
Old 10-12-2012, 03:42 PM
dromero5 dromero5 is offline
Registered User
 
Join Date: Dec 2010
Location: Montrose, CO
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
I just ran this cam in my last 383 TBI. Let me give you some quick specs of what i did. I ran 454 injectors around 16psi, 50mm TBI, and a matched Edlebrock 3704 50mm intake. I ran the same cam with Trick flow 1.6:1 narrow body rockers. I had KB 135 pistons i believe with a Trickflow 23 degree 195 cc runner heads with 64cc combustion chambers. Was a 383 scat setup. I had Brian custom tune me a chip took about 3-4 tries to get it dialed in via datalogging. Engine ran really strong did start losing power past 5000 but the bottleneck was in the 2bbl TBI setup so a standard 4bbl intake with a TBI adapter would have been an upgrade with the EGR tuned out of chip. Unfortunately after 2 oil changes i went to synthetic and the cam went flat really quick so now i sold the shortblock and have the heads and TBI stuff in garage collecting dust. So word of advice the cam can be run but with the appropriate heads and valvesprings and break in is crucial and always run with zinc additive. I would really recommend you look at the 8-304-8 roller cam and stay away from flat tappet cams. I was running 9.6 compression with the pistons in the hole .006 and a .039 gasket. Hope this helps some.
Reply With Quote