350 TBI stalling issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-09-2011, 07:21 PM
Registered User
 
Join Date: Jul 2011
Location: cape coral FL
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 TBI stalling issues

got an 89 chev C1500 350 TBI, at an idle at operating temp it shudders until it shuts off, i have officially done everything i can think of i just need another path to take any ideas??

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-09-2011, 07:24 PM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Nine Mile Falls, Washington
Posts: 5,217
Wiki Edits: 9

Thanks: 99
Thanked 130 Times in 121 Posts
Changed thread title, should get more responses.
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-09-2011, 07:58 PM
Registered User
 
Last photo:
Join Date: Mar 2007
Location: Corinth, MS
Posts: 591
Wiki Edits: 0

Thanks: 0
Thanked 25 Times in 24 Posts
Clogged cat convertor?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-10-2011, 02:33 PM
455olds's Avatar
Registered User
 
Last photo:
Join Date: Jun 2011
Location: Baker City,OR
Posts: 402
Wiki Edits: 0

Thanks: 6
Thanked 49 Times in 47 Posts
Does it restart right away. I had one that would not restart for hours and it was a bad pickup coil. Coolant Temp Sensor failing? Try Chevy Talk also.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-10-2011, 02:39 PM
Registered User
 
Last photo:
Join Date: Jan 2009
Location: Springfield, MO
Age: 29
Posts: 1,100
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
I was thinking control module, but it really sounds fuel related to me with it sputtering before it stalls.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-11-2011, 08:25 AM
Registered User
 
Join Date: Jul 2011
Location: cape coral FL
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
so not temp sensor or pick up coil or control module it starts right away but i already replace all those along with the whole distributer so i got the pickup stator as well and the egr but most of the problem was cause by a clogged check valve on the brake booster which i replaced as well along with fuel pump both injectors fuel filter batt and alt and timing chain and iac tried plugs untill the platinum delcos. finnally the truck does it only at opperating temperature and not as often but there is still something wrong i was gunna try the IAT next wish me luck

oh and i gues sputtering would be a bad description of what it does its more of a looping idle i wish i had a tac so i could be more spacific but its like itll rev up a bit and then idle so low it shakes also i forgot to mention that the oil pressue gauge will spike and fall with the idle and then maintain normal while the truck idles normal
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-11-2011, 10:55 AM
GMCBEAST's Avatar
Registered User
 
Join Date: Apr 2011
Location: Kingsport, TN
Age: 33
Posts: 62
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Had a similar prob with my '88 Jimmy and it ended up being O2 sensor. Drove me crazy, of course it was one of the last things I thought of. Hope this helps.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-11-2011, 12:03 PM
Race The Truck
 

Last journal entry: Son's Truck
Last photo:
Join Date: Mar 2006
Location: Arizona
Age: 58
Posts: 645
Wiki Edits: 0

Thanks: 4
Thanked 1 Time in 1 Post
I will tell you with out a scaner and a shop manual to read what the computer is tell you its a shot in the dark most common problem are the ground wires iac egr fuel pump water temps which the computer read to adjust the timing and fuel! Now all then little do dads have a range that they run in and if there bad or out of adjustment. you will never know with out a scaner! and like me when I got my 89 your just throwing part at the problem! Welcome to the computer age!!
Also you might want to go Here! www.fullsizechevy.com They eat walk and talk trucks!

Craig
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-11-2011, 02:14 PM
Registered User
 
Last photo:
Join Date: Jan 2009
Location: Springfield, MO
Age: 29
Posts: 1,100
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
I was wondering about the IAC and possibly vacuum leaks myself.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling out or something? FiLkY tha FELON Engine 3 05-22-2006 07:57 PM
new sbc stalling bigolblackie Engine 3 04-22-2006 07:54 PM
350 TBI stalling crshrmn3 Engine 13 03-17-2004 02:13 AM
350 tbi stalling out punk1c5040 Engine 0 02-12-2004 08:48 AM
350 tbi stalling out punk1c5040 Engine 1 02-12-2004 08:47 AM


All times are GMT -6. The time now is 12:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.