350 timing problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 04-23-2012, 09:17 PM
Registered User
Join Date: Apr 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 timing problems

I am having getting the timing right on my 350zz crate engine, I thought I did everything right, but it always pings under load. I have tried a few different ways to timing, it seems like every time I time it with the timing light, a few weeks later it moves off its mark. Not sure what could be the problem. Can anyone offer some suggestions. In neutral or park I can rev the engine and there is no pinging but as soon as I put a load on it, its as though there are marbles in the engine. Thanks appreciate ur help

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 04-23-2012, 10:41 PM
68NovaSS's Avatar
Hotrodders.com Moderator
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Nine Mile Falls/Suncrest, WA
Age: 69
Posts: 5,629
Wiki Edits: 9

Thanks: 197
Thanked 202 Times in 184 Posts
It just sounds like your timing is way out of whack. What is it set at static, at idle, distributor vacuum disconnected and plugged? Should be around 12 to 14 deg for starters, and no more than 34 or 36 total.
When I die I want to go peacefully - in my sleep, not yelling and screaming like passengers in my car...

Midnight Sun Street Rod Association

Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing problems darren rogers Engine 11 10-11-2010 10:23 PM
timing problems 350 Wildwestshow Engine 8 09-28-2010 08:04 PM
chevy 350 timing problems Wildwestshow Engine 5 09-24-2010 05:54 PM
sbc(350) timing mark problems jw4413nv Engine 6 08-29-2006 03:29 PM
Timing Problems 80 Chevy C10 Engine 15 09-12-2002 09:33 PM

All times are GMT -6. The time now is 05:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.