350 trans problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-04-2012, 06:30 PM
Registered User
 
Join Date: Aug 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 trans problem

my dad and I have been rebuilding his 76,77 vett for the last 2yr,long story short took it out for a test run and she ran great . the next day he came out to a puddle of trany fluid. so we pulled the tran's removed the converter and found fluid coming out from the bottom of the pump, so we replace the main and the gasket behind the pump and the rubber ring gasket around the pump. put it back in and once tightin back down can not turn the shaft by hand but if reloosen the pump bolts can turn the shaft,any answers.and now cant get the pump back off something is catching it inside its loose but is being held by something inside.

Last edited by vett head 76'; 08-04-2012 at 06:42 PM. Reason: needed to explain more
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-05-2012, 06:26 AM
eloc431962's Avatar
Evil Wicked Mean And Nasty
 
Last wiki edit: Pilot bearing and bushings
Last journal entry: roof repair
Last photo:
Join Date: Nov 2008
Location: back in the garage.
Posts: 13,758
Wiki Edits: 37

Thanks: 50
Thanked 28 Times in 24 Posts
It honestly sounds to me like you may have something in wrong and your going to have to pull it back out and redo what you just did and do it in steps and take time to line everthing up and that it is pulled up correctly and tightened up properly. JMO But someone else might come along and have a better idea but this is just what i would do to do it right.



Cole
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 turbo trans problem hayjen75 Transmission - Rearend 2 03-13-2012 01:17 AM
GM 350 trans problem H_A_S_R Transmission - Rearend 2 02-23-2012 07:14 PM
turbo 350 trans problem. twentyeighty Transmission - Rearend 2 11-17-2009 11:12 PM
Turbo 350 trans problem CK10 Transmission - Rearend 3 10-27-2009 10:17 PM
350 trans problem impala metro Transmission - Rearend 2 03-19-2008 07:39 PM


All times are GMT -6. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.