350 trouble - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-26-2003, 04:00 PM
chevy79's Avatar
Registered User
 
Join Date: Nov 2003
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 350 trouble

I have a 350 in my 79 chevy all was fine till one day it started clanking & i lost oil pressure so i changed the oil pump thinking that would fix it but it still clanks does any body have an idea

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-26-2003, 04:21 PM
Thom Laybourne's Avatar
Member
 
Last photo:
Join Date: Sep 2003
Location: CA
Age: 72
Posts: 448
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Clanky

When you had it open for the pump, did you inspect the sleeves? Look for marks on the walls. Clank vs tap is usually rod related. Lack of oil to the wrist pins.. broken rings.. Check the plugs (why dont people check those things anymore?) Plugs can tell you alot. Color / grit on them / oil.

Good Luck.

hr41pearl
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.