350 turbo vent tube - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-05-2004, 02:21 PM
Member
 
Join Date: Oct 2002
Location: south carolina
Posts: 32
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 turbo vent tube

I took my 350 turbo equipped 7 sec. drag nova to the track 9-3-04 I have not raced it for 12 weeks. On the third pass, the car lost trans fluid and traction, and they had to clean the track. The only thing I can see under the car is a hole in the top on the driver side of the 350 turbo, the hole is clean and the unit runs and shifts. My parts manager thinks that a mud dopper clogged the vent tube and when it blew ...out came to pressure and fluid. Is that even possible?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-05-2004, 04:53 PM
stu stu is offline
Member
 
Last photo:
Join Date: Aug 2004
Location: Saskatchewan
Age: 73
Posts: 428
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
not really

Excess temperature or overfilled more than likely.
Do you have an external cooler?
You should have.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-05-2004, 05:49 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,117
Wiki Edits: 0

Thanks: 25
Thanked 266 Times in 249 Posts
I encounter the mud dauber problem all the time. One of the first thing I have to do on a stored car around here is get them out of trans vents and door, hood and trunk edges.. I also learned long ago to keep air cleaners with elements on the carbs..
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.