350 will not rev on 3300 rpms - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-15-2011, 11:08 PM
HOTRODtwan80s's Avatar
Registered User
 
Join Date: Mar 2011
Location: riverside ca,
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 will not rev on 3300 rpms

Hi everyone , can anybody help out , when I drive my el camino it will not let me get over 33000 before it starts chocking out until I get out of it ,?? In park I can rev real high , can anybody out , ???

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-16-2011, 12:24 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,658
Wiki Edits: 0

Thanks: 15
Thanked 59 Times in 56 Posts
Sounds very much like lack of fuel or plugged exhaust system. What exhaust system is on the car? Check the carbs float level, check the fuel pressure, fuel filter. Need more info on combo, is it stock? Street rod? What cubes?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-16-2011, 04:21 PM
HOTRODtwan80s's Avatar
Registered User
 
Join Date: Mar 2011
Location: riverside ca,
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
350 will not rev over 3300 rpms

Its a 350 , its stock , with a edelbrock fuel pump, & 650 holley carb, & edelbrock intake also , LOL LOL its. My 80s hotrod . I have headers too with no cat, ????
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-16-2011, 04:44 PM
Registered User
 
Last photo:
Join Date: Jul 2004
Location: At Speed
Age: 51
Posts: 1,345
Wiki Edits: 0

Thanks: 2
Thanked 29 Times in 29 Posts
Restricted fuel flow sounds most likely. As a test, temporarily remove any filter between the pump and the carb and test drive. While fuel line is disconnected, start engine and verify that you have sufficient fuel flow. Inspect the fuel line between the pump and the tank for restrictions, especially in any rubber hoses that might be sucked closed by the pump draw. Current pump gas in pretty hard on any rubber parts, and I have seen rubber hose separate the inner liner from the outer casing allowing the liner to suck closed.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-16-2011, 04:45 PM
Registered User
 
Join Date: Feb 2011
Location: Roland Iowa 50236-0486
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Have you checked the timing, Mabe the advance is not working or stuck {vac-advance}
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-16-2011, 04:54 PM
Registered User
 
Join Date: Mar 2003
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Bad coil, it happened on my blown 383 Vette!
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-16-2011, 05:08 PM
CALI4N1A's Avatar
Registered User
 
Last photo:
Join Date: Jan 2011
Location: San Diego
Posts: 27
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
check for a carb vacuum leak (tightening or get a new gasket). A leak could stop your secondaries from opening under load -yet work fine when parked.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-16-2011, 05:19 PM
eloc431962's Avatar
Evil Wicked Mean And Nasty
 
Last wiki edit: Pilot bearing and bushings
Last journal entry: roof repair
Last photo:
Join Date: Nov 2008
Location: back in the garage.
Posts: 13,762
Wiki Edits: 37

Thanks: 50
Thanked 28 Times in 24 Posts
Quote:
Originally Posted by HOTRODtwan80s
Hi everyone , can anybody help out , when I drive my el camino it will not let me get over 33000 before it starts chocking out until I get out of it ,?? In park I can rev real high , can anybody out , ???
Is it doing this during gradual normal driving acceleration or are you getting in it and when it hits 3300 RPM it acts up ?

Oh and if you are actually hitting 33000 RPMs well that's your problem. sorry i could not resist myself.
Cole
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 03-16-2011, 06:12 PM
HOTRODtwan80s's Avatar
Registered User
 
Join Date: Mar 2011
Location: riverside ca,
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
LOL LOL thanks , I ll check all that when I get home
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 03-16-2011, 06:14 PM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
Quote:
Originally Posted by HOTRODtwan80s
LOL LOL thanks , I ll check all that when I get home
Be sure the choke is open, and not flopping shut. How old is the timing set?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What should my rpms be? prettyboyced Engine 22 12-30-2010 09:43 PM
no RPMs Blue Tattoo Engine 7 08-27-2010 10:27 PM
rpms down mkjarobinson Engine 2 11-19-2008 09:36 PM
Max RPMs? Doubleclutch Engine 5 06-03-2007 08:55 PM
rpms low77ride Engine 11 12-02-2003 03:56 PM


All times are GMT -6. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.