351c - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Introduce Yourself
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-10-2005, 05:09 PM
Registered User
 
Join Date: Jul 2005
Location: California
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
351c

Hello all I'm trying to make my 351C I rebuilt work well in my Pantera. I'm having a performance problem,,,, Stinks.... plugs are white... lean? any help?

Steve

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-10-2005, 06:34 PM
aka Duke of URL
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Oct 2001
Location: Rockville, MD
Posts: 4,821
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
Is it stock with the MOTORCRAFT 4300 Series Carb or have you switched to HOLLEY or EFI?

By stinks do you mean it smells hot? White plugs read lean mixture.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-12-2005, 10:39 PM
Registered User
 
Join Date: Jul 2005
Location: California
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
351C running poorly

I'm using an Edelbrock 750CFM with Edelbrock perfonmer intake manifold . Plugs are white when I test drive . Does'nt seem to produce power it should
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-13-2005, 12:51 AM
aka Duke of URL
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Oct 2001
Location: Rockville, MD
Posts: 4,821
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
Unusual...An EDELBROCK usually runs close out of the box.

Did you try and diagnose with the installation directions that came with the carb (they also tell how to fine tune).

Fuel pressure/delivery correct? You don't want it to run lean for too long as engine damage is most likely.

Can you describe the engine modifications and type of ignition system in use?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-13-2005, 08:35 PM
Member
 
Join Date: Nov 2004
Location: rio de janeiro
Posts: 224
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Are you checking the color after running it at WOT for at least two gear ratios?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-14-2005, 12:12 AM
Registered User
 
Join Date: Jul 2005
Location: California
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
351c

I disasembled the slightly used Edelbrock carb. I bought used, The stamping on the carb shows 1407 but the jets and metering rod numbers are the same ones used on a 1411, which is an "economy " tuned carb. There lies the problem I think. I have ordered a 1480 Edelbrock calibration kit which will allow me to fine tune the carb.

I'm running 10.2-1 , trw forged flat top pistons with closed chambered heads.
Cam wise: 110 degrees lobe centers 232 intake and 226 exhaust duration with .529intake and .542 exhaust lift. Duraspark 2 ignition.

any further input would be welcomed
Reply With Quote Quick reply to this message

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
351C build ?'s and input voodoosurfer Engine 23 09-30-2011 02:47 PM
351C needs help fast PlEASE! Steve-0321 Engine 6 11-23-2004 12:42 PM
351C Questions Psychobilly79 Hotrodders' Lounge 5 08-27-2004 02:51 PM
351w, 351c, and 351m intake manifolds El Retardo Engine 4 08-08-2003 10:41 PM
351c ID MarcR Engine 1 11-04-2002 04:13 AM


All times are GMT -6. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.