Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 37 Chev with Mustang II Alignment Question
View Single Post
  #5 (permalink)  
Old 11-30-2012, 06:08 PM
Unks37 Unks37 is offline
Registered User
 
Last photo:
Join Date: Nov 2012
Location: Cincinnati, Ohio
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Many thanks for all the help!! I hope to attach some photos to help answer questions. The front end is from a 1976 Mustang II not an aftermarket. It has the strut rod and I don't know if it was moved during the alignment. They wouldn't let me under the car but I could see in rack from the waiting area along with the computer screen of the adjustments and readings. The first photos is of the front end showing the strut rod. I will have to take some more to show the rubbing of the rear of the upper A Arm on the frame. The second is a photo of the alignment screen showing the computer readings. I took it with my phone. I have a paper copy if any questions. I couldn't help by add the third photo of the car.

I haven't really driving it much since the alignment as I am getting some knocking noises that I am trying to track down. I did find that the track bar on the rear makes a noise when you rock the rear of the car. I am also looking at the rubbing of the A Arm on the frame. This has to be making some noises especially when a wheel drops downward from normal ride height.

There are some other issues to deal with, but I wanted to get the "foundation" (alignment, suspension, brakes, etc) right before working on the rest of it.

I really appreciate all the comments and help!
Regards,
Unk

[/IMG]
[/IMG]
[/IMG]
Reply With Quote