390 FE block in a '56 Mercury - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-26-2008, 09:36 AM
Member
 
Last photo:
Join Date: Apr 2004
Location: Royal Oak, MI
Age: 42
Posts: 173
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
390 FE block in a '56 Mercury

Alright, my question is if anyone has experience that tells them any particular original engine mount works well for a FE block mounting into a Y-block Ford frame, in particular a '56 Mercury. I have an opportunity where I might request to buy some engine mounts at a discount to make up for a shipment of the wrong engine mount for my '55 Mercury which I'm doing everything original on.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-05-2008, 07:32 PM
Registered User
 
Last wiki edit: General Motors transmissions Last photo:
Join Date: Mar 2006
Location: near Yellowstone park
Posts: 4,267
Wiki Edits: 27

Thanks: 11
Thanked 247 Times in 232 Posts
the stock ones

50 years ago i did the y block to fe swap and i just used the original mounts. it seems like you either turn them around or left to right but I didn.t have to buy new ones... the rubber on the originals shear off so most replacements have a retainer system build in.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
428 heads for a 390 Fe Crazy_John69 Engine 9 11-08-2011 06:21 PM
Ford 390 FE hesitation/dead spot namesake Engine 7 08-31-2007 09:02 AM
Need advice on 390 FE Alternator Upgrade!! texastomeh Electrical 14 08-31-2007 04:20 AM
Filling holes on a '56 Mercury roof Slipangle Body - Exterior 5 07-27-2004 06:32 PM
need help to identify my FE block bunnman Engine 10 04-28-2003 11:22 AM


All times are GMT -6. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.