396 bbc back fire through carb - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-04-2012, 02:11 PM
Registered User
 
Join Date: Jan 2012
Posts: 22
Wiki Edits: 0

Thanks: 6
Thanked 0 Times in 0 Posts
396 bbc back fire through carb

iv got a old school 780 holley on it it was back firing through the carb when i would rev it up or when you would be going down the high way giving it gas going through the gears or if you would stomp on it it would pop and it wouldnt go very good so i advanced the timing thinking it was retarded to much but it didnt go away and i replaced the power valve still same thing. i switched carberators to a 600 double pumper just to see if it still did it. it still did. no mater how little or how much timing i give it. it still back fires and doesnt drive good at all but suprizingly it idles pretty good. if i advance to much i pops out the exaust. the engine only has 25 miles on it. it has 550 hp 650 ft of torque.


any help would greatly be appriciated im out of ideas-

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-04-2012, 02:16 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 13,177
Wiki Edits: 326

Thanks: 795
Thanked 1,091 Times in 902 Posts
If you used a flat tappet cam, one or more of the lifters/lobes could be goin' South. Remove the valve covers with the motor idling and observed the rocker arm movement for each valve. If you find one or more that are lazy, the cam is roached and you have shrapnel throughout the motor. Time for a tear-down, good cleaning of all galleys and a rebuild with a roller cam.
Reply With Quote Quick reply to this message
The Following User Says Thank You to techinspector1 For This Useful Post:
matt406 (11-04-2012)
  #3 (permalink)  
Old 11-04-2012, 02:26 PM
Registered User
 
Join Date: Oct 2011
Location: Mo
Posts: 148
Wiki Edits: 0

Thanks: 0
Thanked 6 Times in 6 Posts
I think the first thing I'd look at would be the plug wires, make sure their not crossed and that their well separated. Dizzy cap can cause stuff like this too. Thats a pretty high output 396 I hope your using a light and not guessing at this stuff.
Reply With Quote Quick reply to this message
The Following User Says Thank You to hpete For This Useful Post:
matt406 (11-04-2012)
  #4 (permalink)  
Old 11-04-2012, 07:15 PM
Registered User
 
Join Date: Jan 2012
Posts: 22
Wiki Edits: 0

Thanks: 6
Thanked 0 Times in 0 Posts
i figured out the problem the brand new distributer was bad. i replaced it with an old one i had and fixed the problem. thank you for the input
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ever seen Back fire in rear barrells of carb 42rattler Introduce Yourself 2 04-21-2011 04:39 PM
Back Fire through Carb my71F250 Engine 2 09-08-2010 02:42 AM
Back fire through Carb. my71F250 Engine 2 09-07-2010 08:54 AM
back fire in the carb P.H. 88 Engine 8 02-14-2010 11:50 PM
back fire through carb need help!!! 54chevy22 Engine 9 09-22-2006 11:21 PM


All times are GMT -6. The time now is 05:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.