408w Suzuki Samurai - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-24-2005, 06:52 PM
brainsboy's Avatar
brains
 
Last photo:
Join Date: Jan 2004
Location: tampa
Age: 42
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
408w Suzuki Samurai

I know alot of you have been helping me with alot of my problems, and I promised some of you some photos, well now that I can upload now, Here is what all of you have been helping me build

Hey isnt that Royce's carb....






    Advertisement

Last edited by brainsboy; 03-24-2005 at 07:16 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-24-2005, 07:14 PM
Troadster's Avatar
Member
 
Join Date: Jan 2005
Location: Blountville,TN
Age: 48
Posts: 76
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
WOW what a ride. I have a few questions. What are the headers off of?? Were did you mount the raditor?? How wide is the rear end?? In other words please give the 411 on it. I like things different but that is wild. It ranks up there with the Yougo with the 454 Chevy in it. It ran 5.10's in the 1/8 with an all most stock engine.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-24-2005, 07:19 PM
redlightning's Avatar
Member
 
Last photo:
Join Date: Aug 2004
Location: TN
Age: 49
Posts: 1,082
Wiki Edits: 0

Thanks: 2
Thanked 9 Times in 3 Posts
That is awesome!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-24-2005, 07:27 PM
brainsboy's Avatar
brains
 
Last photo:
Join Date: Jan 2004
Location: tampa
Age: 42
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Trodster, the total width from outside of tires is 58". Radiator is in the rear I ran out of room in the front. The motor is a Ford 351windsor stroked to a 408. I built it for nitrous but to be honest its fast enough now. I was hoping to get it to the track to see what I can run, but Im going to finish the rollbar first.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-25-2005, 10:16 AM
camaroman7d's Avatar
Member
 
Last photo:
Join Date: Dec 2003
Location: Vacaville, California
Age: 47
Posts: 2,245
Wiki Edits: 0

Thanks: 3
Thanked 9 Times in 9 Posts
Ben,
That is a wild ride. That should be fun to cruise around in. Took me a few seconds to figure outthe engine compartment trying to figure out which was was forward. The headers and the distibutor in the fron threw me off. Definetly finish the roll bar before you head to the track, that thig is going to be fast and with a short wheel base things can get interesting.

Nice looking carb too, LOL

I would love to see peole faces when you pull up in that.

Royce
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-25-2005, 10:29 AM
4 Jaw Chuck's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Mar 2002
Location: Manitoba, Canada
Age: 46
Posts: 4,900
Wiki Edits: 0

Thanks: 0
Thanked 72 Times in 60 Posts
Wow thats one wild ride, I'll bet she turns some low 11 second times if you can get it to hook up. How is the cooling of the engine so far?
__________________
Outlawed tunes from outlawed pipes
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-25-2005, 10:53 AM
brainsboy's Avatar
brains
 
Last photo:
Join Date: Jan 2004
Location: tampa
Age: 42
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 4 Jaw Chuck
Wow thats one wild ride, I'll bet she turns some low 11 second times if you can get it to hook up. How is the cooling of the engine so far?
The radiator is 43 inches wide and is a 4 core. Right now anything under 25mph it runs about 150-160 degrees. Crusing at 60mph runs 200-210. I havent built it yet but I need to get an air damn under the car to pick up the air, once I do this crusing should be in the 180 range.

Im having second thoughts about waiting to run at the track, Im thinking about going tomorrow and making a pass just to see.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-25-2005, 11:02 AM
HemmiGremmie's Avatar  

Last journal entry: 52 truck
Last photo:
Join Date: May 2002
Location: Chillicothe Ohio
Age: 47
Posts: 1,406
Wiki Edits: 0

Thanks: 3
Thanked 0 Times in 0 Posts

Thats a bad *** ride!
I thought my Gremlin was a crazy idea, but your is way insane. I like it.
Definatly get a track time on it. HG
__________________
I was built with the body of a God! To bad it was buddah.

[url]http://www.hotrodders.com/forum/journal.php?action=view&journalid=2415[/url]

Hemmies rat journal below.

[url]http://www.hotrodders.com/forum/journal.php?s=f6d0e9c7fec644bb0a70761c0431939b&journalid=84231&action=view[/url]
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 03-27-2005, 08:51 AM
brainsboy's Avatar
brains
 
Last photo:
Join Date: Jan 2004
Location: tampa
Age: 42
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I made it to the track this weekend. Took my 1st run pretty easy at 11.04, I went to do a second run and they stopped me and got list of safety things I need to change, gloves, 5 point harness, shield on helmet,....

By the way the MPH was pretty low at 114 granted I wasnt trying to make the fastest time ,because I wanted to feel the car out, but seems it should of been higher, what causes a low MPH in the quarter?
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 03-27-2005, 01:13 PM
camaroman7d's Avatar
Member
 
Last photo:
Join Date: Dec 2003
Location: Vacaville, California
Age: 47
Posts: 2,245
Wiki Edits: 0

Thanks: 3
Thanked 9 Times in 9 Posts
Ben,
That's awesome for a first pass. Your MPH is low, that could be because of several things. Your cam? Gear? What was the RPM at the traps? You should be able to get pretty deep in the 10's with ease. You will add some weight with the roll bar but it is well worth it. Going fast is fun, going fast safely is even better. Get that thing safe before you hurt yourself. I bet they didn't expect you do lay down a time like that. I would have loved to have seen their faces.

Is it still laying over on you in the upper RPM range? Your MPH tells me something is not right in the upper RPM range, could be timing, you might want to play with that. Could be fuel delivery, did you ever mount a gauege where you can see it? If not I suggest you do even it it is just taped to the windshield for testing.

Very Cool

Royce
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 03-27-2005, 01:20 PM
crazy larry's Avatar
Member
 

Last journal entry: better comparison before and after shots
Last photo:
Join Date: Oct 2002
Location: East Texas
Age: 42
Posts: 2,298
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
just couldn't wait could you?

can't blame you, neither would i.

shiny side up man.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 03-27-2005, 05:14 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Headers

Doc here,

HAPPY EASTER TO YOU AND YOURS!

Awesome ride dude!

Did you Swap the headers left to right (upside-down) , then add and weld pipe to get them to route through the front like that?

Did that once in A Buick/into Toyota swap, It looks kinda familiar ....

Either way, have you considered that they might be adding heat to the water pump and hoses, and the front of the engine, from the headers heating up under load? (hence the higher road temps..)

Might try fabricating a heat shield there, Then take it out for a ride and terrorize the town... and see if the temps go lower...Had similar problem with the Toyota...

Had an 89 sidekick I was considering an SBC in about 5 years ago....but after watching the 4 cyl rattle the body apart I took a pass on the project..After seeing yours...kinda wish I had gone ahead with it...

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 03-27-2005, 05:25 PM
4 Jaw Chuck's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Mar 2002
Location: Manitoba, Canada
Age: 46
Posts: 4,900
Wiki Edits: 0

Thanks: 0
Thanked 72 Times in 60 Posts
Quote:
Originally Posted by brainsboy
I made it to the track this weekend. Took my 1st run pretty easy at 11.04
I can pick em!
__________________
Outlawed tunes from outlawed pipes
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 03-27-2005, 07:23 PM
Troadster's Avatar
Member
 
Join Date: Jan 2005
Location: Blountville,TN
Age: 48
Posts: 76
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
That was a great first pass. I know I would need a change of underwrear.And I had a heating trouble like that on my ride. I ended jetting it up eithet 2 or 3 sizes up and have not had trouble since. I think it was 2 sizes.
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 03-27-2005, 08:30 PM
brainsboy's Avatar
brains
 
Last photo:
Join Date: Jan 2004
Location: tampa
Age: 42
Posts: 988
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It sure was fun, Although I only ran an 11, it felt like low 10's off the line. It hooked up awesome. The torque on this motor is outrageous. The whole front came off the ground good solid 2 foot, the rear end must be little bit off, because the car pulled to the right until the front end landed down. Whats interesting my datsun ran 10.70's and its 60 foot was 1.65-1.69. This car had a 60 foot of 1.46

Royce, I never did put your pump on, I had an old girlfriend that came over so I was debating on to stay home with her or goto the track, I finaly decided to take both to the track. I didnt pay much attention to the fuel pressure, the front end coming up off the ground took me a little by surprise. I crossed the finish line at 6000rpm. The top end seems a little weak. The bottom end under 4500 is just killer, from 4500-6500 its still fast but not like the lower end. I think 224@.050 duration just is not enough for a motor this size, what do you guys think?

Doc, I had to make the headers, I tried running some upside down and it didnt work. Took me about 2 months to make those.



Ben
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.