Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   4L60E when in rev feels like brakes are on (http://www.hotrodders.com/forum/4l60e-when-rev-feels-like-brakes-221613.html)

honeyhush 07-13-2012 12:29 AM

4L60E when in rev feels like brakes are on
 
I have a rebuilt 4L60E that was just rebuilt. All gears shift good but when you put it in reverse it is like you are on the brakes with the emergency brake on. The engine hardly revs up even when floored. Any ideas? I tried to send it back to the people that built it but they are avoiding me. Long story but lesson learned. When I talked to them about it, they said there is something wrong with the valve body. Do I need to replace the valve body or is there a part I can change without taking the valve body off. it is in a 96 z71 and I am trying not to take it back out if possibable. Thanks in advance

Ripper 410 07-15-2012 09:41 AM

Hate to say it but sounds like you have to pull it back out the 4l60e does have some issues in the valve body that should have been addressed when it was rebuilt however the symtoms you are explaining could also be leaking lipseals are clutches improperly installed in the rev drum or damaged hard parts like sprags, etc.


All times are GMT -6. The time now is 04:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.