'56 Gear Box - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-20-2002, 03:45 AM
Seon's Avatar
Member
 
Join Date: Jul 2002
Location: Northern Ca
Posts: 275
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post '56 Gear Box

Just bought a '56 and noticed that the steering gear box has oil leak. It's so bad that it splattered on the exhaust pipe when driving home from purchasing it. Need to know what the fix is? What type of oil for refill? I may change to 605 pwr steering later.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-20-2002, 06:19 AM
New Member
 
Join Date: May 2001
Location: Cloquet ,MN.
Posts: 23
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

You need a new pitman shaft seal,Chicago Rawhide number CR11055,I used Lubriplate 105 assembly lube in mine,but I think you can also use regular chassis grease,just thought 105 was a little lighter and seems to work just fine for me.....good luck
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-20-2002, 07:27 PM
Seon's Avatar
Member
 
Join Date: Jul 2002
Location: Northern Ca
Posts: 275
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Papa, thanks for replying. Today I thoroughly cleaned the gear box, drove 25 miles and re-checked it. Appears that the leak is coming from the top where the steering shaft enters the gear box. I don't think it's leaking from the pitman arm but will also change anyway. Would you know what the part number is for that seal in the upper area? Also, by using chassis grease, how do you get the grease in the box? Drill and tap for a zerk fitting? And if I use grease, it shouldn't leak as the lube oil in the gear box is now? BTW forgot to say in the original post that it's a '56 Chevy Bel Air.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.