60 Impala Brake Light Problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-07-2008, 06:12 PM
Registered User
 
Join Date: Aug 2008
Location: Portland, Oregon
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
60 Impala Brake Light Problem

Hi all, my first post here hoping I can get some input on what might be going on with my 60 Impala.

Well the short of it is, my Brake Lights and Back up lights do not work. I have replaced the brake light switch, and the main blinker switch as suggested by my father since all my light wires run through it. The weird thing is, my brake light fuse has NO power with the key off, but it has power with the key on. The brake and back up lights share the same fuse.

Here is what I know so far.

-Fuse is good (replaced it twice so far just in case, was never blown)
-Fuse has NO POWER when the key is OFF
-Fuse has power when the key is ON
-Tail lights and blinkers all work fine, no issues.
-Replaced and tested the brake light switch, seems to be working fine
-Replaced all my bulbs

Ive talked to a few people and they are all confused but agree that it is probably something simple we are over looking.

Ideas???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-07-2008, 09:10 PM
Holder350's Avatar
Auto Parts Professional
 
Last photo:
Join Date: Feb 2005
Location: Whitesburg, TN
Posts: 1,037
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Bad ground, common on the early 60's chevys
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange amps light problem 78transam Electrical 8 12-04-2006 04:46 PM
It's a Mustang II, but what's in it? And a brake problem . . . hduff Suspension - Brakes - Steering 4 11-19-2006 06:00 PM
What will cause the BRAKE warning light to come on? colin911 Engine 5 09-01-2006 03:00 PM
How Does This Stuff Work? docvette Electrical 3 06-18-2006 03:00 AM
Hotrodders Knowledge Cluster: Disc Brake Conversions Jon Suspension - Brakes - Steering 0 08-29-2003 03:34 PM


All times are GMT -6. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.