65 Impala 327 Question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-27-2004, 04:30 PM
EazyDuzIt102's Avatar
1965 Impala SS Convertible
 
Last photo:
Join Date: May 2003
Location: Antioch IL
Age: 28
Posts: 330
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
65 Impala 327 Question

Hey Everyone.When I went out to my Impala today,I went to start the car but the engine wont turn over.I am allmost 100% sure it is the starter.The battery isnt dead because I have power in the radio and interior lights.If anyone knows anything else it could be,please reply.Thanks

Eazy

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-27-2004, 04:37 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 17,031
Wiki Edits: 5

Thanks: 24
Thanked 331 Times in 258 Posts
Cances are the battery is extremely low. It takes a ton more power to crank the starter than to power the radio etc.

Turn the headlights on and crank the engine. If the lights get real dim, the battery is low.
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-27-2004, 05:21 PM
EazyDuzIt102's Avatar
1965 Impala SS Convertible
 
Last photo:
Join Date: May 2003
Location: Antioch IL
Age: 28
Posts: 330
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I did what you said and the lights didnt dim at all.Everything stayed lit.So I am allmost positive it is the starter.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-27-2004, 05:30 PM
SAATR's Avatar
Member
 
Last wiki edit: Header design
Last journal entry: And still more pics...
Last photo:
Join Date: Dec 2003
Location: Shreveport, LA
Age: 29
Posts: 247
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
It could also be the ignition switch. My truck did the same thing, sometimes it would start fine, others it wouldn't even try, and then one day it just gave up entirely. Doesn't mean that yours wouldn't just up and die either. Pull the starter and test it with another battery. If it spins good and strong, you've either got a bad ignition switch or faulty wiring.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.