66 el camino - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-22-2012, 12:11 PM
Registered User
 
Join Date: Dec 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
66 el camino

powerglide trany is leaking out through the splines through the yoke. Can't firure out why. Any ideas?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-22-2012, 12:41 PM
delawarebill's Avatar
Registered User
 
Last photo:
Join Date: Mar 2009
Location: delaware
Posts: 1,269
Wiki Edits: 0

Thanks: 16
Thanked 67 Times in 67 Posts
leak'n

bad seal...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-22-2012, 01:18 PM
Registered User
 
Join Date: Nov 2012
Location: Atlantilc iowa
Posts: 425
Wiki Edits: 0

Thanks: 0
Thanked 26 Times in 26 Posts
he's right bad rear seal easy fix just drop the drive shaft and pull it out remove old seal and put in a new one and replace drilve shaft. any tranny shop can do that in no time flat.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-23-2012, 09:16 AM
cranky1's Avatar
Just stuck
 
Last photo:
Join Date: Apr 2008
Location: Pasagetdowndena, TX
Age: 63
Posts: 434
Wiki Edits: 0

Thanks: 14
Thanked 0 Times in 0 Posts
If it's leaking through the splines, you can change all the seals you want and the leak won't stop. It's most likely the cap or welch plug in the back of the yoke leaking. You'll need to pull the yoke off the u-joint to get to it. Either replace the yoke or clean it and seal the plug.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-23-2012, 02:25 PM
joshp83's Avatar
owner of Prices Garage
 
Last photo:
Join Date: Jun 2011
Location: west virginia
Age: 31
Posts: 317
Wiki Edits: 0

Thanks: 0
Thanked 23 Times in 23 Posts
proble worn bushing or yoke
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
72 el Camino Zumpy72 Introduce Yourself 5 10-13-2010 02:55 PM
El Camino 1979 Camino Introduce Yourself 2 08-19-2008 07:45 PM
el camino alecatalecat2 Introduce Yourself 3 07-28-2008 08:35 AM
my el camino ss downtempoking Engine 3 07-13-2005 08:15 PM
71' El Camino sscamaro_510 Engine 6 12-09-2004 12:56 AM


All times are GMT -6. The time now is 10:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.