66 El Camino steering pump issue - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-03-2010, 02:04 AM
truckboy61's Avatar
Registered User
 
Join Date: May 2009
Location: california
Posts: 254
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
66 El Camino steering pump issue

I'm switching out My 327 that has power steering and replacing it with a 454 in my 66 el Camino and do not have the power steering brackets for the BB. I was thinking of using a hose to place on power steering box so fluid will continue to circulate ? Will this work if not any ideas on how to handle it ? If I should chose to leave it off will there be long term issues?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-03-2010, 05:33 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
Not having the pump with a PS system makes steering very stiff.....would be almost impossible to drive.......You need to have a pump or put a non power steering box on it.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-03-2010, 01:06 PM
truckboy61's Avatar
Registered User
 
Join Date: May 2009
Location: california
Posts: 254
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
The pump and belt are completely off and it feels like typical non power steering, however fluid pumps out turning either direction? And there is no motor in at this time I assumed after placing the BB in the weight would increase difficulty ?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
this is a saver.... GM build codes TooMany2count General Rodding Tech 24 11-23-2009 09:36 AM
Which waterpump? Eagle1 Engine 5 08-06-2004 06:38 PM
Power Steering for 1959 El Camino w/348 bigfred1958 Suspension - Brakes - Steering 0 05-17-2004 09:48 PM
power steering from long water pump to short water pump kellyem Suspension - Brakes - Steering 7 02-22-2004 07:22 PM
66 el camino 66 c-10 rear end swap? Echofive Transmission - Rearend 0 01-30-2004 10:47 PM


All times are GMT -6. The time now is 09:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.