66 impala wiring issue - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 08-12-2012, 08:44 PM
Registered User
Join Date: Aug 2012
Posts: 3
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
66 impala wiring issue

can anyone tell me where to check for a fault i had very dim dash lights but now no tail lights or dash lights and the fuse is not blown i replaced the headlight switch and ensured proper contact but its not resolved , i bypassed the switch on the plug itself and the rear taillights work fine which tells me the problem is between the dash and headlight switch or column any help is much appreciated thanks

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 08-12-2012, 09:25 PM
Dennis W. Parks
Join Date: Jan 2012
Posts: 56
Wiki Edits: 0

Thanks: 3
Thanked 3 Times in 3 Posts
Have you verified that you have a good ground for your lights? Electricity is weird that it will run through the path of least resistence. To diagnose electrical problems, you really need a multimeter or voltmeter so that you can verify where you have 12 volts and where you don't.

Dennis W. Parks
Author of automotive how-to books
Reply With Quote Quick reply to this message
The Following User Says Thank You to WriterDennis For This Useful Post:
66impalaman (08-13-2012)
  #3 (permalink)  
Old 08-14-2012, 03:44 AM
EOD Guy's Avatar
Registered User
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 2,449
Wiki Edits: 0

Thanks: 2
Thanked 203 Times in 190 Posts
Try hooking a temp jumper between a good ground and the headlight switch ground, sounds like you've got a bad dash ground.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
alternator wiring issue. 56dodge Electrical 4 08-19-2010 06:02 PM
64 Impala SS - Door Closing Issue 64Joker Hotrodding Basics 2 12-23-2009 03:52 PM
Chevelle BB wiring issue!! tempestwagon64 Electrical 7 05-23-2009 01:31 PM
Calling the DOC..66 Impala headlight switch issue black66 Electrical 7 06-01-2006 03:46 PM
wiring issue gilby246 Electrical 2 03-20-2006 09:57 PM

All times are GMT -6. The time now is 09:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.