67 Camaro Tail Light problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-03-2012, 08:32 PM
Registered User
 
Last photo:
Join Date: Dec 2011
Posts: 10
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
67 Camaro Tail Light problem

Bought a 67 Camaro and having trouble with brake and tail lights. Took it to electrical shop who kept it for 2 weeks. Now, headlights work, signals work, park lights work (front), but tail lights, brake lights and back-up lights don't.

Here is the head scratcher. Occasionally, the tail lights and brake lights will come on. We've seen them, but they don't stay on. Another curious occurence is that the tail lights, when they are on, seem to brighten and dim as the engine accelerates.

Any assistance, pointers or suggestions welcomed!! Appreciate it.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-03-2012, 08:45 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,840
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
Sounds like you have some seriously deficient grounds.

Vince
Reply With Quote Quick reply to this message
The Following User Says Thank You to 302 Z28 For This Useful Post:
Toddtex (11-03-2012)
  #3 (permalink)  
Old 11-03-2012, 09:04 PM
Registered User
 
Last photo:
Join Date: Dec 2011
Posts: 10
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Appreciate it! Vince

I'll check the grounds. Thanks!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-03-2012, 09:54 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,840
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
Also check all the connections for loose or melted plugs. I am assuming the car still has OEM wiring.

Vince
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-04-2012, 03:05 AM
EOD Guy's Avatar
Registered User
 
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 2,060
Wiki Edits: 0

Thanks: 1
Thanked 133 Times in 124 Posts
Your tail light bezels arn't making a good ground with the bulb sockets and/or the sockets are corroded.

As far as the lights surgeing..... that's due to the under powered alt, as the engine speeds up the alt produces more juice... so the lights get brighter, as you turn on more assy they will get dimmer etc....... best thing I ever did for mine was to convert the old external regulator to a modern internal regulated, more powerful, alt. It was as simple as unbolting the old alt, installing the new one, removing the external regulator, jumping the four wires from the old reg, replacing the pig tail on the alt and adding a new feed wire.

I used a painless re-wire kit and re-wired mine took two weekends, cured all my electrical gremlins. It was very straight fwd and easy to do.
Attached Thumbnails
Click image for larger version

Name:	12sialt.jpg
Views:	630
Size:	19.3 KB
ID:	68949  

Last edited by EOD Guy; 11-04-2012 at 03:13 AM.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED tail light problem rusty duck Electrical 8 10-18-2012 10:07 PM
87 cutlass tail lights and dash light problem theguesswho Electrical 2 09-09-2012 08:05 AM
tail light problem cares Electrical 2 04-05-2008 10:17 AM
Bonneville Tail Light and Turn Signal Problem darksider Electrical 3 01-09-2008 01:30 PM
brake light, turn signal, tail lamp problem worknprogress72 Electrical 6 01-06-2006 12:20 AM


All times are GMT -6. The time now is 02:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.