67 camaro wiring problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-02-2004, 08:01 PM
shclayto's Avatar
Registered User
 
Join Date: Dec 2004
Location: New Bern, NC
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
67 camaro wiring problems

I have a 67 camaro and have had some wiring issues for a while. The latest scenario is such: first of all, the dim lights work fine, but I don't have any bright lights. second, when I engage the lights (parking and/or headlights) both turn signal lights come on and stay on but only inside the car. the actual turn signals themselves work fine on the outside. I believe it to be a grounding problem, but where should I start troubleshooting? Any ideas?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-02-2004, 08:09 PM
Member
 
Join Date: Nov 2004
Location: rio de janeiro
Posts: 224
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Try lowering the steering column and removing the cluster.Clean every connection and plug.Same with fuse box.High resistance on these old harnesses play games with us.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.