6volt Sparton Horns - problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-09-2009, 03:50 AM
Registered User
 
Join Date: Jun 2009
Location: U.K
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
6volt Sparton Horns - problems

I have a pair of 6volt Sparton horns one of which works and the other just moans - any ideas ? any links ? which might help me ?

These are from my 1948 Packard 22nd Series Six Export Touring Sedan

    Advertisement

Last edited by meaarch; 06-10-2009 at 12:27 PM. Reason: Adding photos
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-09-2009, 07:03 AM
Ziggy1805's Avatar
Grand Curmudgeon
 
Last photo:
Join Date: Aug 2008
Location: Silver Spring, MD
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I am assuming you have the extended bell, 1920's Sparton horn. If so, then take the back off, clean and lubricate it and all should be fine. They used a motor to generate the Ahooga sound.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-10-2009, 12:17 PM
Registered User
 
Join Date: Jun 2009
Location: U.K
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
6volt Sparton Horns - problems

Hi Ziggy1805

No my horns are on a 1948 Packard so are quite different to the 1920's Sparton horn.

Thanks all the same Michael
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
help on installing two horns vanislander Electrical 8 12-29-2008 12:01 AM
How do I wire up my horns? cpthowdy Electrical 6 07-13-2008 10:11 PM
BBC stroker problems? rynophilia Engine 2 07-08-2003 04:20 PM
Holley Carb Problems.. Meangreen Engine 8 06-24-2003 08:00 AM
LT1 knocking problems gollygwagen Engine 0 04-23-2003 05:52 AM


All times are GMT -6. The time now is 10:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.