Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 700R4 stuck in reverse
View Single Post
  #1 (permalink)  
Old 11-27-2008, 10:07 PM
famous 4130 famous 4130 is offline
You forgot more than i know
 
Last photo:
Join Date: Nov 2008
Location: Tucson, AZ
Age: 26
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
700R4 stuck in reverse

Ok so this site has been VERY helpful so far but i still cannot track down an answer specific to my problem.

I just bought a very clean 1989 suburban. the guy sold it cheap because he parked it after a drive and upon starting it again it, every gear was reverse.

i looked at the truck the governor was a brand new unit, the TV cable seemed well connected, the fluid was clean and at the right level, the wiring harness was clean and installed, the shift linkage was A-OK, and all in all the tranny seemed to be in good shape.

i started the truck in neutral, it seemed to be in reverse already. i put it in park and stabbed the gas a bit THEN it went into park, otherwise every gear including neutral was reverse.

i am thinking all signs point to a stuck valve in the valve body or a disconnected shift linkage. if thats the case what is the likelyhood that a trans-flush and a filter would help un stick it.

the tranny has around 20,000 miles on it, i'm twenty years old and everything i know about trannys i have learned from this site over the last three days so i'm pretty damn new to this.

THANK YOU VERY MUCH TO EVERYONE FOR YOUR ADVICE!
Reply With Quote