700r4 troubles - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 03-07-2010, 05:42 PM
emmott.kelsey's Avatar
Registered User
Join Date: Mar 2010
Location: Edmonton, Alberta
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Same Issues

Hey bro I got the same problem with my truck now.

Was 4x4ing in my '87 Jimmy, and used 4-high to get unstuck. After 10 minutes of hard revving, I got the thing out.

I took it out for a wash today, and it started driving exactly the same way that you've described. I couldn't describe the symptoms better than you have.

What did the shop say about your problem?
Was it the TC or a loose/clogged filter?

(And there is no issues with the fluid level. It's a lil burnt, so I can tell where the oil-line is.)

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 03-07-2010, 08:50 PM
Crosley's Avatar
Global Moderator
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris Front suspension
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,718
Wiki Edits: 1659

Thanks: 659
Thanked 196 Times in 177 Posts

Welcome to Hotrodders.

You posted to a 4 year old thread... the original poster has not logged on in 2 years.

I split off your post to a new thread for better views and answers.
Dont worry how old you are... it is the mileage on your body that adds up.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.