Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   71 Camaro power steering problems (http://www.hotrodders.com/forum/71-camaro-power-steering-problems-215207.html)

Hacksaw 02-23-2012 09:28 AM

71 Camaro power steering problems
 
My buddy just bought a 71 Camaro that is 90% restored. It has been setting for awhile but has a new engine, transmission, etc. the power steering doesn't work. He changed the pump with a new one but it still is hard to turn. It's like it is just not getting fluid through the gear box. He jacked it up and turned it lock to lock for 30 min trying to get air out, but acts like its just not responding. Could the gear box have an obstruction? I've never had to deal with this problem before. Thanks

Canzus 02-23-2012 01:14 PM

Sounds like the pressure relief valve is stuck open...
Try this, with the car running, run the steering all the way hard in one direction, does the pump
load up and belt squeal??

Hacksaw 02-23-2012 03:34 PM

Quote:

Originally Posted by Canzus
Sounds like the pressure relief valve is stuck open...
Try this, with the car running, run the steering all the way hard in one direction, does the pump
load up and belt squeal??

I will be sure and tell him to try that tonight. Is the pressure relief located in the gear box or pump?

Hacksaw 02-24-2012 07:16 PM

There is no squeel web turned to full lok with engine running

Canzus 02-25-2012 12:09 AM

Quote:

Originally Posted by Hacksaw
I will be sure and tell him to try that tonight. Is the pressure relief located in the gear box or pump?

In the pump, try google for an exploded view...

Hacksaw 02-25-2012 06:26 AM

Strange how this thing is. It is doing the exact same thing, no power steering, even with the new pump. I guess the new pump could be bad? Should he take it back since its under warrantee and try another one? What if that doesn't help? Then it has to be gear box right?

firebird7980 02-26-2012 05:52 PM

Try lifting front wheels off the ground and see if it still hard to turn. It could be steering linkage binding if it is unhook on thing at a time and see if it get easier

Hacksaw 02-26-2012 07:08 PM

Quote:

Originally Posted by firebird7980
Try lifting front wheels off the ground and see if it still hard to turn. It could be steering linkage binding if it is unhook on thing at a time and see if it get easier

Mechanical steering is fine. It just acts like it is a non power steering vehicle. It didn't work with the old pump, and still not working with a new pump.


All times are GMT -6. The time now is 05:05 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.