'73 Courier... - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-29-2008, 01:16 AM
AmericanPackMule's Avatar
Registered User
 

Last journal entry: Adolessent J.R.
Last photo:
Join Date: Feb 2004
Location: Los Angeles, Calif
Age: 71
Posts: 151
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
'73 Courier...

Starts Right some times. But some times, Real hard starting. With a little Grinding Noise. Barely turning over! ( A Remote Kill Switch, Adjustable Viltage, Control?)

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-29-2008, 08:42 AM
F&J F&J is offline
Registered User
 

Last journal entry: 32 Ford cabriolet conversion/windshield
Last photo:
Join Date: Mar 2007
Location: Connecticut
Age: 62
Posts: 1,571
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
I would guess you don't have the tools to do a starter "draw" test, checking the amps used when cranking?

Hard to diagnose without hearing it. It might be worn starter bushings? Does the starter itself get hot when it is barely turning over? That would indicate a dragging of the armature from bad bushings.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-29-2008, 08:54 AM
AmericanPackMule's Avatar
Registered User
 

Last journal entry: Adolessent J.R.
Last photo:
Join Date: Feb 2004
Location: Los Angeles, Calif
Age: 71
Posts: 151
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
'73 Courier ( Starting...)

Well: I forgot to mention, that it has a { NEW: BATTARY - Starter - Cables - Fuse Holder & 40 Amp. Fuse. } It is the 1750 c.c. Engine! 65,000 Miles on the Odomiter. ~~~ I'm going to the Auto Parts Store Today, With intent to get the Block of a 2300 c.c. ready for rebuilding. The Head Next Week.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making a '80 Pontiac T/A a '73 T/A sorta clone? LanceM Body - Exterior 8 08-26-2009 07:24 PM
73 firebird inkwork Interior 1 02-28-2007 08:14 PM
Will a 390 fit or work in a 73 Mustang..... onebadmerc Engine 4 12-08-2005 10:57 AM
73 Dart Sport parts interchange? dadeeoo Electrical 0 04-12-2004 12:39 PM
Big block for my 73 Nova Hatchback? 73 Nova Guy Hotrodders' Lounge 7 02-26-2003 11:40 AM


All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.