73' sbc running rich in the #2 cylinder - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-16-2012, 08:06 PM
69novassguy's Avatar
Registered User
 
Join Date: Oct 2012
Posts: 19
Wiki Edits: 0

Thanks: 6
Thanked 0 Times in 0 Posts
73' sbc running rich in the #2 cylinder

I have a 73' 350 sbc with edelbrock performer rpm heads, torker II intake, edelbrock 750 carb (primary jets .107, secondary .98, metering rods .68x.42) hei super coil, msd spark wires and accel header plugs on my 69' nova ss and the #2 cylinder plug keeps fouling out....ive been tweeking the carb because it was running very rich and it seems like no matter what i do i cant fix the problem. ive been consulting the charts and diagrams in the manual and it still wont fix it. sometimes its dry carbon and sometimes wet. any help would be great thanks...

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-16-2012, 11:40 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 13,313
Wiki Edits: 326

Thanks: 838
Thanked 1,152 Times in 951 Posts
One possibility: Intake manifold gasket is wrinkled or doesn't cover the port correctly and that cylinder is pulling in oily crankcase vapors when the intake valve is open on that cylinder. This does not explain the dry carbon on the plug. I'd begin some detective work on the distributor cap and wires.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-16-2012, 11:45 PM
prostreet6t9's Avatar
Differential/Driveline
 
Last photo:
Join Date: Sep 2008
Location: oregon
Age: 51
Posts: 1,761
Wiki Edits: 0

Thanks: 9
Thanked 45 Times in 42 Posts
Have you done a compression check on #2 hole?
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
running rich badknuckles Engine 16 04-30-2011 09:17 PM
283 SBC suddenly running rich and sputterin eatonde Engine 7 09-20-2008 08:23 AM
Still running rich 77ChevyBigTen Engine 5 07-11-2006 04:21 PM
Need help -- SBC running rich all of a sudden jodz Engine 6 09-05-2003 09:59 AM
Rich Running 400 Sbc Help !!!!!!!!!! Sampson Engine 4 07-01-2003 10:18 PM


All times are GMT -6. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.