Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 74 chevy c10 ignitiont no power PLEASE HELP!
View Single Post
  #7 (permalink)  
Old 11-02-2012, 12:50 AM
theguesswho theguesswho is offline
Registered User
 
Join Date: Aug 2011
Location: canada
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
running lights wont come on and head lights wont come on, no radio no wipers no nothing, when i put the key in and turn it to the on position not a thing happends. the steering coloum thats in it everything works fine on it the ignition is fine i know that and its all wired up right, i didnt see no burnt or corroded wires or anything when i was installing it, like i said for some reason when i went out the next day it was working so i wired everything up and i fired up the truck a few times, and then like 5 hours later my buddys wanted to see the fancy lights on it and i turned the key to the on position and when i pulled out the light switch to turn on the running lights everything died right away, and id turn the ignition forward and the oil and gen light would light up but try turning on the running lights or wipers and the power would get cut, and now for some reason the oil and gen light wont come on now, i dont understand it becuz tomorrow i could walk out to it and everything might work fine again, thats whats been happening, the truck doesnt move around or anything, i still have to put the box back on it, its been in the same spot for the past 2 weeks, one day it will work fine and the next ill go to turn on the lights or start it and my power will get cut, if i leave it , it seems to suddenly work after letting it sit over night or something thats how its been going, everytime this has happend, id just leave it for the next day cuz i get pissed off at it, and the next day id come out and everything would suddenly work, the most iv gone without it working was like 2 or 3 days then it suddenly came back, i could turn the key in the on position 100 times befor it screws up again or only 3 times befor it screw up again, it works when it wants it seems, witch makes it more hard to figure out what the problem is
Reply With Quote