75 firebird question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-05-2011, 10:40 PM
87fubar's Avatar
Registered User
 
Last photo:
Join Date: Jun 2010
Location: oroville
Age: 28
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
75 firebird question

ok heres what i got po took all the powersteering stuff out before i got the car its got the pont 400 factory 80A alt but i got no brackets to mount up the pump ive try'd seaching the net to see if there diff from the comon pump brackets but cant seem to find much info on the 80A set up if any 1 has a good link or pic's would help out alot


or should i just put the 65A comon stuff on it

    Advertisement

Last edited by 87fubar; 05-05-2011 at 10:48 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-07-2011, 04:53 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,217
Wiki Edits: 0

Thanks: 203
Thanked 258 Times in 240 Posts
I think the difference wouldnt be the PS brackets but more likely the spacer for the alternator pivot point wich is also the pivot for the ps pump.
I looked at the 1973 ps pump and brackets I have and that is what Ithink. I could post a pic. Do you have a pic of what you have?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-07-2011, 06:40 PM
87fubar's Avatar
Registered User
 
Last photo:
Join Date: Jun 2010
Location: oroville
Age: 28
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
the brackets for the alt has 1 looks like a big c its biger then the 65A bracket. the other is aluminum the only thing that looks to mount to it is the alt an uses 3 bolts in line to the head.i have the 65A set up for the pump but it wont line up with the 80A stuff

an wish i could put pic's up
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-08-2011, 06:26 AM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,217
Wiki Edits: 0

Thanks: 203
Thanked 258 Times in 240 Posts
this is the basic setup I guess.Obviously different from what you are trying to get to.
Attached Images
 
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-08-2011, 04:05 PM
87fubar's Avatar
Registered User
 
Last photo:
Join Date: Jun 2010
Location: oroville
Age: 28
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
the alt mount i got is in the way for the pump bracket that mounts to the head

those are the brackets i got on the shelf
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-08-2011, 07:59 PM
willowbilly3's Avatar
Member
 

Last journal entry: Body mods
Last photo:
Join Date: Jun 2004
Location: Black Hills, South Dakota
Age: 61
Posts: 1,208
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Maybe you could go back to the stuff that all worked together and run the small frame 65 amp. If you need more juice, those can be rebuilt to make 100 amps.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 05-08-2011, 08:08 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,217
Wiki Edits: 0

Thanks: 203
Thanked 258 Times in 240 Posts
Here are a few pics. Not sure what aluminum bracket you mean.I dont think the alternators are anything over 63 amp, but I like pictures, they help keep it real.
I think the first pic is a better representation of the setup. The second is too old as I think it is a 65 , the first is a 73
Attached Thumbnails
Click image for larger version

Name:	73_00060_3.jpg
Views:	44
Size:	131.3 KB
ID:	55103   Click image for larger version

Name:	105-1_a_s 1965 389 pic.jpg
Views:	42
Size:	21.5 KB
ID:	55104  
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 05-09-2011, 10:13 AM
87fubar's Avatar
Registered User
 
Last photo:
Join Date: Jun 2010
Location: oroville
Age: 28
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
main reason i wanted to keep the stock set up is the po just replaced the 100A alt couple weeks before i got the car

an the aluminum bracket it mounts to the head the lower mounting point of the alt has 2 tabs 1 with just a hole the other a sleave ill see if i can find a pic of that mount on ebay
Attached Thumbnails
Click image for larger version

Name:	ccf8_12.jpg
Views:	41
Size:	36.5 KB
ID:	55109  

Last edited by 87fubar; 05-09-2011 at 10:20 AM.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
75 firebird question 87fubar Engine 7 04-28-2011 08:12 PM
'68 Firebird question: Thinking Man Suspension - Brakes - Steering 5 06-30-2007 09:25 AM
One more 79' firebird question?? Rough-Rider Engine 3 02-12-2007 01:07 PM
engine question on firebird avpdlee73 Engine 2 07-05-2006 10:05 PM
68 Firebird AC Question SouthernRodder General Rodding Tech 3 05-31-2006 10:51 PM


All times are GMT -6. The time now is 03:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.