Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   79 TA, clunk, clunk, clunk sounds under hard steering (http://www.hotrodders.com/forum/79-ta-clunk-clunk-clunk-sounds-under-hard-steering-113535.html)

Gladis 04-10-2007 06:01 PM

79 TA, clunk, clunk, clunk sounds under hard steering
 
My steering has been doing some strange things. It lags, like I turn the wheel, then the car turns a little later. It's not like there's a lot of dead space, it's like it takes the car a little less then a second to respond my steering. It's like a told my friend, it used to feel like I was turning the wheel through water, now it feels like I am turning it through air. Just now, I came around the corner, turning right, and clunk, clunk, clunk, coming from the right front. Any ideas about what is going out on the steering?

russlaferrera 04-10-2007 06:16 PM

Hard Steering
 
Jack it up, take a look see. You probably have a worn steering part, that is making the noise. Check the steering linkage for looseness and idler arm, ball joints for excessive play. You can also check the rubber bushings on the sway bar and upper a frames.

brian0605 04-10-2007 06:20 PM

I would be inclined to look very closely at the wheel bearing!! I would also look at everything else as well but it just sounds like a wheel bearing to me. Brian

Bigolotava 04-13-2007 06:43 PM

I had a buddies car in Hawaii that did something similar to what you describe. It started out the same way... only he had to eventually turn the steering wheel about 1 to 1-1/2 turns to get the wheels to start turning! The problem was later traced to the steering box... Once it was replaced it was fine. Somebody had tried to rebuild it for him and messed up the little ball bearings that cradle the spool in there. I replaced my leaky unit in my '79 Formula with one from NAPA for about $185. It even had the nice, quick 2.75 turns lock to lock ratio!
Good Luck and don't drive it too long in the current condition... Your life (plus whoever's lives you have a head-on collision with) are worth having it checked out!

Gladis 04-13-2007 08:47 PM

the clunk sound is rubber bushing that's gone missing(between the frame and unibody, if that makes sense), the steering is getting more worn, but the idle was too low, so when I was coasting the power steering wasn't getting enough to make the steering fluid. It's still probably needs a few things replaced, but it looks like i am going to try to buy a different car. Who knows though. Thanks for the info, one question though. Steering box, where and what is that? I am a partard.

Bigolotava 04-14-2007 11:45 PM

The steering box (steering gear) is located at the end of your steering wheel and converts the rotation of your steering wheel to L/R motion in the front wheels. If you pop the hood open and look on the driver's side firewall, you'll see the steering shaft that extends from the steering wheel... follow it down to the front of the car and you'll see the steering box connected to it. You'll also notice the hoses from your power steering pump are connected to it too which provide the power assist when the engine is running.
Take Care!

Gladis 04-23-2007 05:51 PM

replaced the wheel bearings and the race thingys they run on, but I'm still getting the clunk clunk clunk sound, also replaced the frame bushings too. Rides a lot better, steers a lot better, but still on those hard left turns it goes clunk clunk clunk. I can feel it too, through my rm that's usually resting on the center console.

1ownerT 04-23-2007 06:19 PM

You could replace parts that may not need replacing and eventually find it. I would do a complete front end check, suspension and steering. There are many possibility's worn or missing control arm bushings, missing control arm shims, bad ball joints, there are so many things.
If you don't know how to check everything, take it to a couple of shops and have them check it and compare the parts list's, get a list and post back on how to fix.

Bigolotava 04-25-2007 08:40 AM

I agree with 1ownerT, get the car checked out by a competent repair facility. I've had good luck with Goodyear in my area.
And at the risk of sounding sexist, I would highly recommend you have a boyfriend, brother or Dad go in with you, as it seems all these places tend to take advantage of women, particularly if you're not the most mechanically proficient... Either way, get it checked out and fixed as you don't want to take a chance on something so important to the safe operation of your car.
Best of luck getting it fixed! Let us know what the problem was. The '79T/A is a wonderful car to drive when the front end end is tight and accurate!

Gladis 04-25-2007 12:32 PM

ha ha ha, I'm a dude, my car's named gladis. ha ha ha

Bigolotava 04-25-2007 02:03 PM

Sorry DUDE!!! (Really!)

My wife gets the "treatment" anytime she takes her car in for work and I'm not there, thus the advice. Funny how many times they want to perform that fuel injection cleaning service!

Anyhow, get your T/A's front-end checked out professionally and let us know what they found... I'm curious as to what it might be. Barring the steering box, I would hazard to guess the upper control arm bushings followed by the lower ball joints. GM recommends servicing the uppers anytime the lowers are changed, so don't be surprised if they suggest replacing them too. The idler arm, center link and tie rod ends could also be suspect given the age of your T/A and the care (or lack of care) it's received over the years.

Good Luck!

brian0605 04-29-2007 09:22 PM

You need to check the rearend, I think that is more than likely where you will find the problem. good luck. Brian

Gladis 04-30-2007 06:03 PM

ya definently my tranny is way over on the passeger side, so when I turn left hard it swings into the wall there and beats on the body. So I'm thinking new tranny mounts.

brian0605 05-01-2007 07:34 AM

yeah that'll do it!! might want to check engine mounts while you're at it.Brian


All times are GMT -6. The time now is 05:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.