79 z28 reverse lights come on in neutral - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-04-2013, 07:16 PM
Registered User
 
Last photo:
Join Date: Aug 2010
Location: VA
Posts: 23
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
79 z28 reverse lights come on in neutral

When I put my 79 tranny in reverse I get no lights, when I move it to neutral the reverse lights come on. If I move it gently back towards reverse it will sometimes stay on. I figure I need to adjust something but I'm not sure if it's the actual linkage under the car or if there is some thing else. Any help (and pictures of which to adjust) would be appreciated. Oh yeah, it's a automatic floor mounted. Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-04-2013, 08:28 PM
gonzo08383's Avatar
Registered User
 

Last journal entry: brakes
Last photo:
Join Date: Jan 2012
Posts: 158
Wiki Edits: 0

Thanks: 2
Thanked 9 Times in 8 Posts
should be a limit switch in the shifter assembly. probably just needs adjustment. pull the shifter cover off and take a look see. should be a tab that engages the switch just look in there it should be somewhat apparent. its real easy if you have a b&m shifter. not overly familiar with the stock shifter. should be relatively close tho.
Reply With Quote Quick reply to this message
The Following User Says Thank You to gonzo08383 For This Useful Post:
Benscamaro (04-06-2013)
  #3 (permalink)  
Old 04-04-2013, 09:01 PM
66GMC's Avatar
Get in, sit down, hang on
 

Last journal entry: Cab Removal
Last photo:
Join Date: May 2005
Location: Olds, Alberta Canada
Age: 56
Posts: 2,761
Wiki Edits: 0

Thanks: 32
Thanked 90 Times in 85 Posts

NAPA Echlin #NS6589 Back-up / Neutral Safety Switch.

This one looks like it's column-mounted, but I would think that there must something similar mounted to the gearshift lever inside the console?

Sounds like it's just out of adjustment ... does it crank properly or do you have to fiddle with gearshift as well?

Some N/S switches used to have an alignment hole that you inserted a paper clip into while in the PARK position to hold it in the desired spot while you tightened the screws to the column?

Not sure on that either, though ...

Edit:
Read This

Quote:
Park/Neutral Safety Switch acts as the reverse light switch and is located down on the column for both column and console applications (GM just didn't change the column/console design and used a backdrive rod from the transmission to turn the column shift lever and vice versa...).

Last edited by 66GMC; 04-04-2013 at 09:17 PM.
Reply With Quote Quick reply to this message
The Following User Says Thank You to 66GMC For This Useful Post:
Benscamaro (04-06-2013)
  #4 (permalink)  
Old 04-06-2013, 09:24 AM
Registered User
 
Last photo:
Join Date: Aug 2010
Location: VA
Posts: 23
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
Reverse light

Thank guys. It does crank fine and I have no problems with the ignition lock. I'll do some poking around to see if I can adjust it.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
4l60 no reverse/forward on neutral matador23uti Transmission - Rearend 2 03-12-2011 10:33 AM
4l60e no reverse first on neutral matador23uti Introduce Yourself 2 03-11-2011 06:50 AM
95 Z28 fogg lights RetiredRodder Electrical 1 03-05-2011 01:34 PM
wants to go in reverse when in neutral mainejohn Transmission - Rearend 6 02-27-2011 05:15 PM
neutral safety/backup lights 67stepsidebeast Electrical 10 10-13-2005 09:14 AM


All times are GMT -6. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.