80 Blazer Issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-17-2012, 11:51 PM
Registered User
 
Join Date: Sep 2012
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
80 Blazer Issues

My Blazer had been having problems with hesitation on initial acceleration,and an idle that seemed not quite right, but would run out decently after that. Now besides the hesitation, it is jerking around, quite a bit on the bottom end, when given more gas it almost dies, and then takes off like a bat out of hell. Everything on the engine, and the engine is new, only one thousand miles, it did not have this problem after the original installation. Occasionally the vacuum canister will smell badly of gasoline, you can smell it 10 feet away. The mechanical fuel pump runs more pressure than it should, and I put a holley regulator on it, after it blew out the Edelbrock I had on it. Now a holley carb is on it. Does anyone think this is a fuel pump issue, a vapor issue, or what? Im going to blow out the lines, which were also new one year ago, and then replace the fuel pump. Anyone who has had this problem, help me out. Would appreciate it. It has a 350 with a 4 Barrel Holley.

    Advertisement
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 Blazer K5 TBI issues. sureshot Engine 4 10-23-2010 04:40 PM
95 S-10 blazer mjascur Introduce Yourself 5 02-26-2010 07:38 AM
blazer markf6029 Suspension - Brakes - Steering 0 09-29-2009 09:51 PM
1996 blazer fuel issues brian berwick Engine 1 08-18-2008 04:04 AM
s`10 blazer blazer434 Engine 2 03-12-2006 05:23 AM


All times are GMT -6. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.