Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   80' chevy c10 parking brake problem (http://www.hotrodders.com/forum/80-chevy-c10-parking-brake-problem-174133.html)

80chevybigten 03-08-2010 08:30 AM

80' chevy c10 parking brake problem
 
I have an 1980 chevy big ten model half ton with a little bit of an issue. I need it to pass a safety inspection. For that my parking brake needs to work. I know what the problem is but not quite sure on how to fix it. on the firewall just above the brights switch and underneath the dash there is a cable that fits into a bracket that sets the parking brake. Right next to the breaker. Right now the cable is not in its bracket. I tried to pull it up with pliers and I got it up a bit more. I got underneath the truck and found the cable and tried to shove it up into the cab and that helped a bit moe as well. I removed the rubber piece on the parking brake pedal so I could raise it higher so the bracket would come closer to the cable and that helped a little. But I need another 1/8 of an inch or so and I cant get it there. Any ideas on what I can do to fix this problem?

joe_padavano 03-08-2010 08:41 AM

Quote:

Originally Posted by 80chevybigten
I have an 1980 chevy big ten model half ton with a little bit of an issue. I need it to pass a safety inspection. For that my parking brake needs to work. I know what the problem is but not quite sure on how to fix it. on the firewall just above the brights switch and underneath the dash there is a cable that fits into a bracket that sets the parking brake. Right next to the breaker. Right now the cable is not in its bracket. I tried to pull it up with pliers and I got it up a bit more. I got underneath the truck and found the cable and tried to shove it up into the cab and that helped a bit moe as well. I removed the rubber piece on the parking brake pedal so I could raise it higher so the bracket would come closer to the cable and that helped a little. But I need another 1/8 of an inch or so and I cant get it there. Any ideas on what I can do to fix this problem?

Follow the cable backward until you find the adjusting nut. Loosen the nut. Hook the cable to the pedal assembly. Readjust the nut.

80chevybigten 03-10-2010 07:55 AM

Oh, why didn't I think of that? I got underneath it to loosen it but the threads and nut are rusted together to the point to where I couldn't turn it. Is there anything you would recommend to loosen the rust up?

fast68 03-14-2010 04:35 AM

PB blaster

and/or some heat on the nut only

vice grips

small plumbers monkey wrenches

sqzbox 03-14-2010 05:29 AM

A line wrench will help not to round off the nut's as well. :D PB blaster is good stuff if you let it work by spraying it on and letting it sit for 12hrs or more. It's not a miracle juice that works instantly, but better than WD-40.


All times are GMT -6. The time now is 11:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.