85 camaro rear end problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-20-2008, 08:03 PM
Registered User
 
Join Date: Sep 2008
Location: iowa
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
85 camaro rear end problems

i have an 85 camaro used to have v6 now runing a 350. stock rear end non posi. speedo is off bout 15mph. i get a howl at speeds over 70 and some smoke but only when under power not when u coast. help me

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-20-2008, 08:16 PM
Jmark's Avatar
Registered User
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,932
Wiki Edits: 0

Thanks: 13
Thanked 47 Times in 36 Posts
Welcome to the HR forums!

I'll move this to the trans/rear end forum for, hopefully, lots of suggestions.

Mark
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-20-2008, 08:41 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
Sounds like your 350 has smoked your weak 7.5" rear.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-20-2008, 11:10 PM
curtis73's Avatar
Hates: Liver. Loves: Diesel
 
Last wiki edit: How to find cheap parts
Last journal entry: Found an LQ9 today
Last photo:
Join Date: Dec 2005
Location: Carlisle, PA
Age: 41
Posts: 5,312
Wiki Edits: 16

Thanks: 20
Thanked 22 Times in 17 Posts
It has probably wasted the bearings in the rearend, but that wouldn't cause smoke.

The smoke is probably an oil leak, or its burning oil that is leaking past the valve seals or rings.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear end swap required & I'm cunfussed datsun dale Transmission - Rearend 8 12-17-2008 10:03 AM
85 Regal rear end dilema Regal Beagle Transmission - Rearend 5 04-19-2008 07:11 AM
67 camaro rear end question shclayto Transmission - Rearend 6 10-11-2005 10:24 PM
96 camaro rear end fit in 84 regal 225buick Transmission - Rearend 5 04-18-2003 05:10 PM
Rear end swap problems datsun dale Transmission - Rearend 1 12-17-2002 11:50 PM


All times are GMT -6. The time now is 12:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.