86 vette seat & door lock problem... - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-06-2006, 06:36 PM
Registered User
 
Join Date: Jun 2004
Location: West Ohio
Age: 64
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
86 vette seat & door lock problem...

The Drivers seat, (only one thats power), & the door locks have failed. The Breaker is too hot to handle. Any suggestions? plus i am having a hard time locating the relays...

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-07-2006, 03:48 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,

That Circuit breaker handles both If I remember right..

Sounds like the seat is "Rotor Locked" , motor or seat jambed in a the tracks where the motor can't overcome the opposing force. you need to pull the seat and inspect the tracks and the motor drive for a locked Condition.

Is this Corvette standard seat? or a Riccarao (SP?) , I don't show a schematic for the seats in that year..Does it have position memory and heat? If so those relays will be found in a box under the seat.

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-07-2006, 04:50 PM
vicrod's Avatar
life is a ride
 

Last journal entry: 2014
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 71
Posts: 1,310
Wiki Edits: 0

Thanks: 0
Thanked 56 Times in 52 Posts
To expand on the Doc's post.
You may have a seat or a window switch that is stuck. This will cause the motor to be always trying to run but cannot because it's at the end of it's travel.
The circuit breaker will "trip" OFF due to the high current draw of the stalled motor. When the circuit breaker cools, it will reset ON and again trip OFF as above.
Try to isolate the windows from the seats to rule out which system is causing the problem.
Start by disconnecting the wires at the seat motors. And check to see is the windows work OK. Then reconnect the wires one at a time, noting when the problem occurs. Likewise with the windows.

vicrod
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-07-2006, 04:55 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,

Thanks Vicrod!

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-12-2006, 07:36 PM
Registered User
 
Join Date: Jun 2004
Location: West Ohio
Age: 64
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
86 Corvette Seat Problems

Thanks Fellows, I sure appericate your time and effort. The seat is just a factory unit, no memory or heat. It just goes up and down, and forward and reverse...I had a chance to remove the front track nuts, but haven,t had the time to go any further.. Hopefully this week my scheudle will slow down a bit so that i can try to finish the job...Sure want to finish this so that the little woman can enjoy her toy...Thanks AGAIN, And I,m In-the-Weeds...
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 Saturn Transmision Problem dmg53 Transmission - Rearend 4 01-18-2006 06:59 PM
74 Corvette Brake Problem iniguy Suspension - Brakes - Steering 7 07-02-2005 04:46 PM
please help..... annoying warm start problem 67cuda Engine 21 03-28-2003 05:44 AM
350 turbo in vette problem mikeweyman Engine 2 03-26-2003 07:00 PM
Fuel / Carb problem DoubleVision Engine 5 10-28-2002 05:18 PM


All times are GMT -6. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.