88 s10 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 09-19-2013, 05:31 AM
Registered User
Join Date: Sep 2013
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
88 s10

Here's the deal...I have a 88 s10 and when you first start it, it will run good for a minute or so then it goes to sputtering. Well when it starts the sputtering u can turn the key off or kill it then restart it and it'll run good again for a minute. Over and over any ideas on this would be greatly appreciated as I'm trying to get it going by 9/21/13. Thanks in advance.

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 09-19-2013, 05:33 PM
LATECH's Avatar
Hotrodders.com Moderator

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 6,104
Wiki Edits: 0

Thanks: 324
Thanked 435 Times in 392 Posts
Ignition problem. Coil or module.
Fact is stranger than Fiction
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
will s10 pickup fit S10 blazer chassis? peab007 Hotrodding Basics 4 02-28-2012 08:45 PM
S10 V8 silas_552000 General Rodding Tech 5 01-15-2007 04:52 PM
need some more s10 help 89silverado454 Transmission - Rearend 4 10-28-2006 08:44 AM
S10 pickup or S10 Blazer frame? raj4851 Hotrodding Basics 10 01-06-2006 09:28 PM
v8 s10 Selwyn3III Engine 9 02-21-2004 02:30 PM

All times are GMT -6. The time now is 07:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.