88 Thunderbired Question, Need Help - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-13-2003, 04:49 PM
Registered User
 
Join Date: Aug 2003
Location: Auburn, Ga
Age: 58
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 88 Thunderbired Question, Need Help

I need help with a problem on my 88 Thurnderbird.

When I let go of the ignition the moter turns off! Seems like the ignition switch is shot. Any ideas or methods I can do will be greatly appreciated. Thanks Mike Smith

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-13-2003, 05:40 PM
adtkart@aol.com
 
Last photo:
Join Date: Oct 2002
Location: Newport News, VA
Posts: 3,220
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Change the ignition switch. I just had the same problem with my mother-in-laws car. My son changed the switch and took care of it. Was told by several people at the Ford dealer that it is a common problem with the column switches. Note that it is the switch itself, not the key cyl.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-14-2003, 03:18 AM
Member
 
Last photo:
Join Date: May 2003
Location: Shreveport LA
Age: 64
Posts: 5,103
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There was a recall (due to fires) on the ignition switches on those cars. Give you VIN to a Ford dealer & they should be able to tell you if it has been replaced already. If not, maybe they would fix yours. Also, the switch may be loose on the column.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-16-2003, 04:50 PM
Registered User
 
Join Date: Aug 2003
Location: Auburn, Ga
Age: 58
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Talking uslogic

Thanks Guys, I'll take your advice and let you know how it works.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.