Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - '89 5.7 TBI stumble/dying on light acceleration
View Single Post
  #6 (permalink)  
Old 06-04-2010, 10:10 PM
Trainwreck Trainwreck is offline
Registered User
 
Join Date: Apr 2010
Location: Washington state
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The truck is FINALLY running great, got the stumble/ hesitation figured out. It has been a learning experience to say the least. Before I explain what I found, I want to thank everybody that jumped in to help me with this problem. you're a great bunch of folks!!

I was out of ideas on what to do on the truck so I bit the bullet and had a tech come out to the house and bring his computer/scanner/artificial intelligence thingamabob.

An hour and half later his advice was to replace the ECM and the muffler! He said the ECM wasn't modulating the pulse width on the EGR, it was signalling the solenoid to open and stay open at any throttle position above idle. His exhaust advice was that the Magnaflow muffler (the only non-stock component in the exhaust system) was causing insufficient back-pressure and messing up the EGR valve.

I thanked him, paid him and sent him away. I wasn't convinced of his diagnosis but went to the wrecking yard and picked up a compatible ECM off a running truck that had the top crunched by a fallen tree. I installed it with no change in symptoms. I just could not accept that the muffler was causing my problem so I ignored the 'replace it' advice. After thinking about it for a couple of day, I decided to go talk to my local parts house about EGR valves. The guy looked up my truck and said that there were two available- one for 8500 lbs. GVWR and lower and one for above 8500 lbs. GVWR. He had both in stock and pulled them out to look at them, they were noticeably different in their design. The light bulb came on over my head and I went home and looked at my engine's EGR valve. My truck is a 8500 and lower truck but had the 8500 and above EGR on it. I went to the wrecking yard again and grabbed an EGR off another truck that matched what I needed. I installed it and...... it runs like a top, 50 miles of around town driving without any issues at all!!

The EGR valve was passing all the tests because it was not broken, it was just the wrong one for my application. What an ordeal! But I'm happy- the truck is running like it should and my blood pressure back down to a reasonable level.
Reply With Quote