89 F250 5.8L MFI, rough surging idle (Code 23) - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-20-2011, 09:40 AM
mike 96 ws6's Avatar
old dog learning new tricks
 
Join Date: Feb 2005
Location: Mississippi USA
Age: 53
Posts: 232
Wiki Edits: 0

Thanks: 10
Thanked 0 Times in 0 Posts
89 F250 5.8L MFI, rough surging idle (Code 23)

It runs down the road fine but the idle is not very smooth. Not a dead miss but the exhaust note is not constant (more like the sound of an aftermarket high lift/long duration cam). The exhaust does not smell rich. Sometimes when idling in gear with A/C on, the RPM surge will get to the point where it will go dead.
I installed new plugs and wires yesterday. (no plugs were fouled but all 8 were pretty white from running lean).
I did find some leaking vacuum lines and fixed them. How do I check for a leaking EGR valve on this truck? (EGR is solenoid controlled, not vacuum controlled / very limited access to try to lift the pintle manually).
How do I diagnose code 23?
I can't tell if TPS is adjustable or not (not very accessible on this MFI arrangement).
Thanks for any help!
Mike

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-20-2011, 01:48 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,658
Wiki Edits: 0

Thanks: 15
Thanked 59 Times in 56 Posts
How many miles are on this engine? If the mileage is high, grab ahold of the throttle and see if it will shake. If it moves it`s worn out from high miles and when the throttle closes it closes at a different place everytime from wear and it`s making the TPS read way off, now you know why it won`t idle.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-20-2011, 02:03 PM
Joe G's Avatar
Registered user
 
Last photo:
Join Date: Nov 2008
Location: St. Paul, MN
Age: 40
Posts: 598
Wiki Edits: 0

Thanks: 80
Thanked 38 Times in 37 Posts
Sounds like it could be a sticky Idle Air Control Valve. It would be simple and cheap to pull it off and clean it.

Good luck....
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-20-2011, 02:44 PM
RippinRon's Avatar
Member
 
Last photo:
Join Date: Jun 2004
Location: Thornbury, Ontario
Age: 34
Posts: 948
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Code 23 is tps out of range. A new aftermarket one may be slotted for adjustment but the stock is not.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-20-2011, 03:05 PM
mike 96 ws6's Avatar
old dog learning new tricks
 
Join Date: Feb 2005
Location: Mississippi USA
Age: 53
Posts: 232
Wiki Edits: 0

Thanks: 10
Thanked 0 Times in 0 Posts
Thanks guy's!!!

Got it running pretty smooth.
Disassembled throttle body and cleaned IAC motor, throttle plates, and adjusted TPS to 0.470 at closed throttle (was 1.670). (hope it stays there. I saw no slack in the throttle plate bushings?).
Thanks for the help everyone!!!
Mike
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle, high idle in park, stalls in gear.. Help! ratmaro Engine 18 03-23-2012 05:29 PM
surging idle bradykat Engine 1 06-06-2010 01:28 PM
1981 Gm 3.6 V6 Rough Idle And High Idle nomaddaddy Engine 1 11-15-2007 09:49 PM
Rough idle Yub350 Engine 1 12-07-2004 01:06 PM
Seeking advice on rough idle; "Y" code 307.. Oldsmolac911 Engine 1 11-14-2002 12:25 AM


All times are GMT -6. The time now is 05:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.