Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 89 GM TBI 350 - Quit Running...Where to Start?
View Single Post
  #1 (permalink)  
Old 04-27-2007, 07:40 AM
Rambo_The_Dog's Avatar
Rambo_The_Dog Rambo_The_Dog is offline
Registered User
 

Last journal entry: Shop Remodel Progress
Join Date: Dec 2005
Location: Pacific Northwest
Posts: 736
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
89 GM TBI 350 - Quit Running...Where to Start?

I just wanted to throw out some symptoms and get some ideas on what to look at before spending a bunch of money.

Bought C30 Step Van Nov 06 - has had history of starting ok but after 15-30 seconds the fast idle would "kick-off" and I'd have to feather the gas until warm.

I lived with it but now that its for sale and I had a potential buyer with me the other day it decided to quit on me 2 miles from my house and had to have it towed back - needless to say I lost the sale

Symptom is cranking over - would start only if foot on gas -(which shouldn't ever be needed with this type of system) and would idle once it cleaned out (was flooded at this point) but as soon as I dropped the truck in gear and try to give it gas it falls on its face and dies

Anyway, while I was waiting for the tow truck - I pulled the air cleaner and cranked the motor over - a lot of fuel was being poured down the throttle body by the 2 injectors.

With the air cleaner off I could get it running as described in above but same thing when dropping into gear it would die but I still noted fuel was still being pushed down the TB - so fuel alone is obviously not my issue...the amount and regulation must be!

Just for fun I pulled the nearest injector wiring-plug so that only 1 injector was active - then the truck started right up and idled as it should, without applying the pedal - but it would still fall on its face when putting into gear and trying to give it gas.

So - this thing is old enough the new readers don't work on them and I need to start troubleshooting. Any ideas?
Reply With Quote