'89 Silverado stalls at traffic lights - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 09-02-2010, 01:48 PM
Registered User
Join Date: Nov 2009
Location: Brandon FL
Age: 58
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
'89 Silverado stalls at traffic lights

Hello Folks I need help. I have a stock '89 silverado, 305 TBI engine 700R4 trans that often stalls at traffic lights when warmed up. Also will stall in parking lots when steering wheel is turned to lock. Running A/C makes it happen more often. Only bad when warm. Otherwise runs just fine gets decent mileage. 185,000 miles.

Problem came on gradually starting about a year ago. Kept happening more and more often now happens almost every traffic light unless I shift into N then maybe it still stalls about 50% of the time. It seems like when I pull up to a traffic light and stop, the engine idles lower and lower until it stumbles and finally stalls. In the last two weeks I replaced:

Plug Wires
Dist. Cap
Air Filter
Fuel Filter

Any advice on what to check next?

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 09-02-2010, 02:03 PM
Registered User
Last wiki edit: Wheelbase database Last photo:
Join Date: Jan 2007
Location: Virginia
Posts: 4,035
Wiki Edits: 1

Thanks: 7
Thanked 241 Times in 220 Posts
Originally Posted by darefugee

Any advice on what to check next?
Idle Air Controller. The TBI on your truck uses a separate stepper motor to control the idle speed through an air bypass passage in the throttle body. This motor can go bad or just get crudded up and not allow the appropriate amount of air to pass for the needed idle speed. The computer in your truck monitors when the A/C is on and even monitors the pressure in the power steering (as an indication of load on the engine) and varies the idle speed appropriately to avoid stalling. Sounds like your IAC is either bad or out of adjustment.
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 silverado dome lights inop. fumplet Electrical 2 04-11-2010 11:32 PM
will 4l60e work in my 89 silverado? It has a 700r4. mojokimble Transmission - Rearend 2 04-21-2006 09:16 PM
89 silverado speed sensor th350 swap pep3 Transmission - Rearend 2 02-21-2006 06:42 PM
89 Silverado starting problem Echofive Engine 8 12-16-2005 09:56 AM
will a 4l60e work in my 89 silverado? mojokimble Transmission - Rearend 2 02-29-2004 11:01 AM

All times are GMT -6. The time now is 02:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.