Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   93 Suburban fuel pump (http://www.hotrodders.com/forum/93-suburban-fuel-pump-68612.html)

sabino56 08-21-2005 07:18 PM

93 Suburban fuel pump
 
I have 93 suburban 5.7l tbi engine, about 170k miles. The fuel gage has gradually gone bad such that only a 1/4 or so of gas is in the tank when the fuel gage registers 1/2 full. Recently, it refused to start. I messed around and convinced myself it's the fuel pump or lines or wires from fuel pump to engine compartment. (i dribbled a little gas down the intake and it starts right up. I checked that fuel relay is working and in-line fuse is OK. There is 12V on the wire after the fuse.) So, a couple questions. I believe the fuel sender and fuel pump are in the same unit in the fuel tank. Is this correct? Any thoughts on the fuel gage error and bad fuel pump being related? I'm wondering if there is a way to tell if fuel pump is bad or wiring to pump is bad without dropping tank. It doesn't look like you can get to any connections, etc. without dropping the tank. Any advice or experience in replacing fuel pump would be appreciated!
Thanks in advance for any help!
Ed

97Z28 08-21-2005 07:31 PM

there should be a single wire, i dont know what color it is you'll have to check a service manual. but its a fuel pump test outlet. all you have to do is put that wire to a 12V source and see if the pump starts. an easy way to check is disconnect the feed line from the motor and put a bucket underit and see if it shoots gas out of it. and if you do get gas, then its not your pump.

and yes, the fuel pump and sender are all in 1 unit in the gas tank.

Kevin45 08-21-2005 07:42 PM

When you turn on the key can you here the pump run. If not, then chances are it is bad. Also replace the filter while you are at it.

sabino56 08-21-2005 08:37 PM

Thanks - I have shop manuals and found that there is a test point for the fuel pump on the diag connector under the dash - slot G. I could not hear pump when putting 12V to it or when ignition was on. I put test light on in-line fuse and could feel relay activate and light would go on when ignition was turned on. Then I put 12V on the downstream side of the fuse connector and pump still didn't seem to come on. I guess it's down to dropping tank.

71 c-10 08-21-2005 09:24 PM

get you a good penitrating oil, my favorate is pb blaster, or aerokroil, aero is kinda expensive but works awsome... Since the tank is prety much empty you shouldnt have to much prolem. maybe the night before or a lil while before you tackle it soak the strap bolts and shoot the top to try and help the hold down ring to losen up. dont try and drop if its full, its prolly a 30 gallon tank.. After that i think its one wire conector and 2 or 3 quick disconect fuel lines and its out. im not 100% sure if its a giant snap ring or a lock ring you hammer side ways to get the pump out. then just make the sure the new one goes in in the same direction as the old and your on your way, fill the tank, the gas keeps the pump cool so it doesnt burn up.

edge 08-22-2005 10:49 AM

Let's assume you have one big tank like my 94' Suburban. If so, here are some pictures to give you an idea of what's involved.

Make sure the tank is as empty as is possible!

Two straps hold it on, pre-soak them as suggested. The tank will come out without having to jack up the rear. You will need a floor jack and a flat piece of wood about 2 foot long. A 2x4 will work okay, but flatter is better. You need to disconnect the filler hose at both ends, as well as the big 5/8" dia. vent hose at filler neck assembly. There is an electrical connection (weatherpack style) that is bolted to the top of the frame rail on the drivers side. This is also where the ground loop is attached. Drop the tank gradually and let it lean to the driver's side. This will allow you to get to the supply and return line couplings, and the other smaller vent lines. Disconnect the fuel lines, the electrical connection, and the smaller vent lines (need pliers) and then allow the tank to slide off the floor jack completely on the ground. Since there should also be hard plastic protective cover, it will allow you to slide the tank without worry of damaging it. If you remove the shield first, be very CAREFUL when dropping and sliding the tank. Pulling it out gives you easy access to the sending unit. Clean it off the top area real good and use compressed air if available prior to removing the ring. After you replace the pump, be sure to use a new O-ring gasket at the top and use grease to lube it, otherwise it may break when reinstalling the ring. Be sure to use the new section of hose that comes with your new pump and also install a new strainer. Buy a new AC-Delco fuel pump if you can find one. Reinstall in the reverse order. And, remember to have a helper when doing this job (lol - see my last picture).

Good luck, Ed www.edgesz28.com

http://www.edgesz28.com/edgesZ28/suburban/tank1.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank2.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank5.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank4.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank7.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank8.JPG
http://www.edgesz28.com/edgesZ28/suburban/tank3.JPG

DUKEOFBLUZ 08-22-2005 06:54 PM

I changed my pump on my 93 burb, 42 gallon tank, the pump was $32 at NAPA

sabino56 08-26-2005 09:13 PM

Thanks for the great pics and instructions!! I'll let you know how it goes. It's going to be another week before I get to it. I've got to work on a tranmission replacement in one of my other cars this week.. bummer.
Thanks again
Ed

sabino56 09-10-2005 02:54 PM

I pulled out unit. Thanks for pics and instructions - it really made is short work. One question - there is alot of sticky type sealant - Do you know what it is?
Thanks
ed


All times are GMT -6. The time now is 01:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.