93 tbi - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-02-2008, 01:43 PM
Registered User
 
Join Date: Nov 2008
Location: oregon
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
93 tbi

i have a 93 1500 z71 4x4 with a 350. when you crank it it over it will not start but if you add a little fuel in the tbi it will start and will not idle but if you do this and keep it above 1000 rpm it will run and drive. i have put a kit in the tbi and a new iac valve. any ideas??????

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-02-2008, 05:08 PM
Member
 
Last wiki edit: Vacuum brake bleeder set up
Join Date: Nov 2003
Location: So Cal
Posts: 1,245
Wiki Edits: 8

Thanks: 0
Thanked 0 Times in 0 Posts
Any codes? What is your fuel pressure? Are the injectors putting out a nice spray or a stream/drip? A timing light can help you see the fuel spray pattern.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-02-2008, 08:54 PM
Registered User
 
Last photo:
Join Date: Jan 2008
Location: Kemah TX
Posts: 425
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Are the throttle blades open a little? If not it can't get fuel and cause the issue you are describing. Try cracking the throttle slightly and crank it see if it starts.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-03-2008, 08:38 AM
racecar100's Avatar
Registered User
 
Join Date: Feb 2008
Location: Tennessee
Age: 54
Posts: 254
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You should have 12 pounds of fuel pressure. If not you need new fuel pump.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help with 1986 GM 305, TBI or Carbed??? dieselcruiserhead Engine 8 12-19-2010 08:32 AM
TBI to carb swap eatonde Engine 20 09-09-2008 12:01 PM
TBI assistance needed jack kelley Engine 5 05-24-2006 11:11 AM
Tbi Mods NAIRB Engine 8 05-03-2005 07:50 AM
TBI Questions on a 93' Chevy FS 350 IWANTMOREHP Engine 1 01-04-2004 02:42 PM


All times are GMT -6. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.