Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   General Rodding Tech (http://www.hotrodders.com/forum/general-rodding-tech/)
-   -   '94 Firebird steering problems (http://www.hotrodders.com/forum/94-firebird-steering-problems-12908.html)

ILjXYZ 04-28-2003 11:33 AM

'94 Firebird steering problems
 
Hey gang,

I bought my 1994 Firebird used about a year and half ago and haven't had any major problems with it at all. I love the car but lately (I'd say within the past few months, actually) it's been acting weird.

Up around certain speeds (between say 55 & 70 mph) the steering wheel will sometimes "shake" or "wobble" from left to right... once I get up around 80 it quits and down below 55 the same thing. Not really sure what is causing this. It wasn't doing that when I bought the car and like I said only recently developed.

More recently, within the last month, it has been running smooth, no shakey steering wheel, but when I get above 60 mph and then come back down in speed (whether via hard braking or coasting) my Service Engine Light comes on as soon as the speedo hits 60. All of my gauges are fine, oil, temp, all of that is tip-top, and like I said it actually is running smooth. The SEL stays on until I turn the car off then back on and then goes away. These 2 scenarios seem to appear at random. One day I'll get intot he car and it'll be shakey steering wheel but no SEL, the next day it'll be smooth but SEL will come on as described above. Now, I'm certainly not a mechanic by any means but I just can't seem to figure out why this is happening.

In an effort to try to figure this out I went to Pep Boys and bought one of those cheap Actron code readers for my car. It is supposed to make the SEL flash when you plug it in to that slot (forget what it's called) and turn your car to standby mode (battery on but engine not running). However, the SEL doesn't flash, it just stays on. I refered to the Actron manual. It said refer to my servicing book. I looked in my Chilton guide and it said that if the SEL stays on during a code read that I might have to have a "drivability technician" look at it. I have no idea what that is but it sounds scary. :>

I really just want to figure this out. My engine should be (and as far as I can tell is) running fine. Coolant, oil, transmission fluid (including dropping the pan) and all that good stuff is changed regularly by my father and me. My father has been a diesel and car mechanic for 20 years and can't figure it out. I know that my shocks are shot and I need to get new ones, but could that cause my SEL to come on?

Anyway, any help would be great... sorry for the long post. :)

-Charlie

Silnod 11-05-2003 04:07 PM

Sounds like fun to figure out. Whell as far as the sterring wheel shaking while you are driving that is more then likally that your sterring assembly is not tight down there. What you should do is sit in you car really quick and turn your wheel back and forth slightly now if your tires do not move at all then you need to have a shop do an alignment to tighten up all of your tie rod ends so that you have no more wheel play. If that is not causing it then have you bought new tires recently, or anything change on your car? if your car is shaking sometimes is it when you press on the brake? becuase if it is that can be caused by your rotors being warped due to overheating. As far as the engine light goes coming on all the time i would ignore it as long as your oil pressure is high and everything is properley serviced on it. let me know about those questions though becuase i have a pretty good idea of what it could be . good luck :thumbup:

Kevin45 11-05-2003 04:36 PM

I would get the front end checked just for safety's sake. I would not ignore the Service Engine Light coming on. They are there for a reason and when they come on something is wrong, It could be minor or it could end up being major. One thing to check that will make a light come on is a loose gas cap. I know it sounds stupid but it just happened to our Solara and Weimer had it happpen to his V-Dub. I forgot it happened and ended up taking it to the dealer. Cost nothing but time and a little embarrassment. It could be an O2 sensor, EGR valve, but it is something that should not be ignored. Just my $.02 worth.

Kevin

UncleFluffy 11-07-2003 08:15 PM

Quote:

Up around certain speeds (between say 55 & 70 mph) the steering wheel will sometimes "shake" or "wobble" from left to right... once I get up around 80 it quits and down below 55 the same thing. Not really sure what is causing this. It wasn't doing that when I bought the car and like I said only recently developed.

Front wheel bearings ?

DesertPanel 11-07-2003 10:26 PM

First thing I would do for the wheel shaking thing is have the tires balanced. Especially if it just happened all of a sudden. You might have just thrown a tire weight. It's happened to me a couple of times, and a simple tire balancing did the trick.

Might be time to bite the bullet and take the 'bird to the dealership for the service engine light problem. Who knows? It might be a freebee recall item.


All times are GMT -6. The time now is 10:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.