Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   94 S-10 manual trans problems (http://www.hotrodders.com/forum/94-s-10-manual-trans-problems-224512.html)

Gary Vey 09-29-2012 08:29 PM

94 S-10 manual trans problems
 
Was offroading and tried to go to 4WD-hi but the light didn't come on. In fact no lights - even when tried to go back in 2WD. So drove home 60 mph about 120 miles when came to stop and then everything was like neutral -- all the gears. Roadside help replaced the electronic switch and got me moving but I'm left with:
*Reverse works fine
*can start out in 1 or 2 no problemo, then shift to D or OD and all is well
*cannot start out in D or OD
*come to stop or slow below 20 mph in D or OD and is like neutral
*NO Engine warning/service lights come on

One mechanic told me low roller clutch and forget it, keep shifting manually.Another told me it was BhiftB solenoid needed replacement.

Now the 4WDhi is not activating... hmmm.

Any suggestions?

joshp83 09-30-2012 06:46 PM

yourpost said manual trans a manual dont have soleniods or roller clutches but if yours a auto it sounds like the the fwd sprag failed wich is internal issue the 4x4 problem is seperate


All times are GMT -6. The time now is 04:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.