Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 95 Dakota 2.5L 4cyl. Runs Rough Help!
View Single Post
  #4 (permalink)  
Old 06-13-2006, 05:03 AM
TT66' TT66' is offline
41' Chevy Master DeLuxe Tudor
 
Last wiki edit: How to title a hot rod
Last journal entry: Engine/Trans Mock-up
Last photo:
Join Date: Jan 2006
Location: Southern Indiana
Posts: 123
Wiki Edits: 2

Thanks: 0
Thanked 0 Times in 0 Posts
I haven't checked the fuel pressure, but i took the converter completely off and by passed it. If you keep the RPM'S up it will run longer without cutting out, but when you let off to idle it it starts running rough. The only way to keep it running is to pump the gas, but it will eventually stall. According to the readout that flashes on the speedometer it's#34 which say's it is either the speed control vacuum or vent control solenoid circuits. It doesn't have cruise control so that rules out the speed control vacuum. I found out that the vent control solenoid controls the vacuum from the fuel cannister to the throttle body. I swapped out 3 different control solenoids and that make any difference. I also checked every vacuum line on the engine with a vacuum pump and found no leaks. I didn't the lines running to the gas tank, but there all metal running from the engine back to the tank.I had a busted head gasket before this all started and antifreeze got into the muffler and exhaust system and it wouldn't hardly run.That's why im wondering if the computer needs reset. Ive had the battery unhooked several times and it don't seem to make any difference. I haven't worked on the newer computerized dodges any and if I get this one running it will be the last one I ever own or work on. Any info you can give me will be greatly appreciated. Thanks for your time and interest.
Reply With Quote