'95 F-150 distributor problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-30-2011, 11:23 AM
Registered User
 
Last photo:
Join Date: Sep 2006
Location: kansas
Age: 68
Posts: 515
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
'95 F-150 distributor problem

kinda my last resort here, Ford truck club won't let me in ..... '95 Ford f-150 with 302, has the fuel system with 4 injectors..... how do I check the distributor ? All was good , till I changed the dist due to a bad bearing. Then the truck quit on me, checked out the ign modual on the fender, was bad, with the new one it ran about 3 days, quit again , won't start. Modual checks out good this time... I have no spark and none to the injexctors....how do I check the signal thing in the distributor ? I think it's a P I P signal ? thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-30-2011, 04:40 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 13,321
Wiki Edits: 326

Thanks: 839
Thanked 1,153 Times in 952 Posts
If you want to work on it yourself, then you may want to buy one, some or all of these manuals. These are original Ford manuals and in my opinion, are the only ones to use. Those Fosdick aftermarket clunkers are worthless. I guess this new EFI and all the gizmos is good for the planet, but it can sure wreak havoc with your wallet. You may come out with a cheaper and quicker fix by letting someone else fix it for you. I spent a ton of money on Faxon original manuals and tools to find the problems with my '91 Ford F-150 4.9 liter. Runs good now, but it SHOULD run good, for all the sheckels I spent on it.
http://www.faxonautoliterature.com/Search.aspx?c=121226
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-30-2011, 04:41 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,434
Wiki Edits: 0

Thanks: 230
Thanked 295 Times in 274 Posts
test the pickup coil resistance with a DVOM.Spec should be between 400-700 ohms.
And X 2 what Techinspector said.. Clymers , haynes and chilton are all useless. They dont even make good TP.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-30-2011, 05:41 PM
Registered User
 
Last photo:
Join Date: Sep 2006
Location: kansas
Age: 68
Posts: 515
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I do have some of the Ford manuals , but the 1 I don't have the one that includes the electric trouble shooting stuff ! I'm going to get that one now , as I can see how complicated this ''new'' stuff is.....I agreee about the chitons , it said my fuel pressure was suppoed to be only 17 pounds ! ( instead of 35 to 40 )..............Anyway , I checked the dist, , replaced the dist, started right up ! This dist (rebuilt NAPA) was only in it for about a week ! NOW, I just wonder how long this one will last....where it will leave me stranded ????????? thanks guys !
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 04-30-2011, 05:54 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 13,321
Wiki Edits: 326

Thanks: 839
Thanked 1,153 Times in 952 Posts
Quote:
Originally Posted by knighthawk
.where it will leave me stranded ?
On 307-A Bypass halfway between Hogjowl and Fiddler's Corner at 2:00 A.M. Oh, and by the way, there's no cell connection out there.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 04-30-2011, 09:12 PM
Registered User
 
Last photo:
Join Date: Sep 2006
Location: kansas
Age: 68
Posts: 515
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
how well I know that feeling ! About a year, traveling with my old motorhome (over 20 years old and 100,000 plus miles on it ) I like to travel at night..... all of a sudden it quit , 2 AM on a 2 lane road ! And I STILL have no idea where it was ! Luckily it did start right back up , and I never slowed down till daylite !
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 04-30-2011, 09:29 PM
66GMC's Avatar
Get in, sit down, hang on
 

Last journal entry: Cab Removal
Last photo:
Join Date: May 2005
Location: Olds, Alberta Canada
Age: 57
Posts: 2,763
Wiki Edits: 0

Thanks: 32
Thanked 91 Times in 86 Posts
No columns of intense white light coming from a strange flying disc above, right?

Guages didn't go crazy, and the radio didn't quit either?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
69 Chevelle distributor problem boone44 Electrical 3 09-30-2009 07:41 PM
Odd distributor problem falinman Electrical 10 01-08-2007 12:43 AM
distributor problem charliec Hotrodding Basics 8 09-06-2005 09:17 PM
352 Distributor problem...please HELP!!! tazzman68 Engine 3 01-28-2005 07:38 PM
HEI Distributor Problem Jag Daddy Engine 3 11-07-2003 12:48 AM


All times are GMT -6. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.